0

Just got this express card yesterday for my x220, I can't seem to find the drivers for this. Here is the card: https://www.amazon.com/Express-Chipset-Adapter-Converter-5-0Gbps/dp/B00J9PAZIO/ref=sr_1_1?ie=UTF8&qid=1471172235&sr=8-1&keywords=express+card+usb+3.0

I tried to google the information they listed under the selling information for downloading the drivers: " NEC/RENESAS USB3 Controller uPD720202 Drivers ", but that is not for ubuntu. i am on 16.04.. I heard these can be hard to install, can any one help me get these drivers installed and anything else I need to do to get it working?

Also, when I run: lspci -nn Nothing shows up about the card. Any help appreciated!

  • What is the output of lspci -nnk | grep -A2 USB? – David Foerster Dec 29 '16 at 15:01
2

Add pciehp.pciehp_force=1 to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub, as detailed in the Ubuntu 9.10 and onwards section of this ExpressCard article. That solved this problem for me.

Specifically:

  1. Edit /etc/default/grub.

  2. Find the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line.

  3. Change that line to say:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pciehp.pciehp_force=1"
    
  4. After saving those changes, run:

    sudo update-grub
    
  5. Reboot.

On my USB 3.0 32G drive, it then showed up automatically.

0

You need to disable Legacy USB support in the Bios once that happens the system the operating system is free to use what it can find and we'll find the D70202 NEC/RENESAS DRIVER TO WORK WELL

The drawback is you lose the ability to boot off a USB stick or USB hard drive. But who cares .... you lose thrvability to come out of hybridization '-- sleep --- properly .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.