1

I ran this code: sudo add-apt-repository -y ppa:fingerprint/fprint sudo apt-get update sudo apt-get install libfprint0 fprint-demo libpam-fprintd gksu-polkit

Then entered my fingerprint with this: fprint_demo It saved. Then I ran this line of code: fprintd-enroll

I then rebooted, it didn't work, still asked for my regular password, I checked the bios, fingerprint scanner enabled. Can any one help me get this working?

0

Please use Fingerprint scanner GUI and it works perfectly on my T450 and X220. The ppa is at https://launchpad.net/~fingerprint/+archive/ubuntu/fingerprint-gui

0

You need to edit the configuration file at /etc/pam.d/common-auth by typing the command sudo nano /etc/pam.d/common-auth and adding the line auth sufficient pam_fprintd.so above the line that reads auth [success=1 default=ignore] pam_unix.so nullok_secure try_first_pass.

4
  • I don't see auth required pam_unix.so, the "required" is missing. This is what I have. Should I add auth sufficient pam_fprint.so above this: auth [success=1 default=ignore] pam_unix.so nullok_secure try_first_pass – Kdrumz Aug 15 '16 at 1:06
  • Yes, you should add auth sufficient pam_fprint.so above the line auth [success=1 default=ignore] pam_unix.so nullok_secure try_first_pass. – gabemai Aug 15 '16 at 1:10
  • Okay, I added that line. I also just restarted and it still won't work. I ran my finger across several times and it doesn't light up or anything – Kdrumz Aug 15 '16 at 1:20
  • Try replacing auth sufficient pam_fprint.so with auth sufficient pam_fprintd.so. – gabemai Aug 15 '16 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.