3

I'm on Kubuntu 16.04, with kde 5.6.5, and window background color is not applying (always the default white)

Here is a screenshot of Doplhin with the Breeze Dark theme, as you can see, some parts of the window stays to the default color. It happens on other applications too, like System Settings, and with other colors/themes.

Dolphin with breeze dark

I tried upgrading to kde 5.6.5 as someone said on Kubuntu Breeze-Dark not working as expected, nothing changed. I created a new user, as suggested on KDE Plasma 5 upgrade has removed my window decorations, but it didn't work.

Same problem as Kubuntu 16.04 Themes do not apply correctly?

Does anyone know how to fix that?

3

I'm guessing you've installed some other GTK based Desktop Environments (Such as Lubuntu or Xubuntu) in your Kubuntu installation. Though the theme changes, they revert back to the ugly Striped look after a reboot. The solution is installing gtk3-engines-breeze.

sudo apt-get install gtk3-engines-breeze kde-config-gtk-style

After installing, Open System Settings -> Application Style -> Gnome Application Style and Change the theme for both Gtk2 and Gtk3 to Breeze Dark.

If the theme doesn't change immediately after applying:

If all the theme component doesn't change to Breeze Dark immediately, Go to Settings -> Workspace Theme and select Breeze Theme by clicking it, this will activate the Apply button. Now, change the selection back to Breeze Dark Theme by clicking it and finally Click the Apply Button.

  • I did what you said, but no luck :/ do you need to restart ? – Keplyx Aug 16 '16 at 16:55
  • 1
    @Keplyx I've updated the answer. Check if it works. It will persist across reboots. I think you've installed some gtk-based themes and using it in other DEs like LXDE or XFCE – Anwar Aug 16 '16 at 17:01
  • 1
    Thank you so much! It solved my color problem, I can now use custom window colors, but to do so I had to select oxygen-gtk for Gtk2, so every colors work, not only Breeze-Dark. What caused the problem is that I selected Breeze for Gtk2. Thank you so much, I was stuck with that problem for months. But the window decorations still don't change, and as I selected oxygen-gtk, I'm stuck with the oxygen decoration. – Keplyx Aug 17 '16 at 17:00
  • 1
    Glad to know that it works. You can mark the answer as solution by clicking on the grey tick mark at the left side of the answer :) – Anwar Aug 17 '16 at 17:12
  • 1
    I think I'll remove the window decoration part of the question so I can mark your post as answer, and make an other post about it. – Keplyx Aug 17 '16 at 17:15
0

These two steps worked for me:

sudo apt-get remove appmenu-qt
sudo apt-get remove appmenu-qt5
0

So I’ve tried everything written so far but nothing worked for me. BUT as soo as I started qt5ct with sudo everything updated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.