2

For some reasons I am unable to install maria db. I did try the following procure but I did not manage to install. I keep getting:

Errors were encountered while processing: mariadb-server-10.0 mariadb-server

I started with

  1. Install the repo manager

sudo apt-get install python-software-properties

  1. Import the GnuPG signing key

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0xcbcb082a1bb943db

  1. I Modified my sources.list file to add MariadDB

deb http://ftp.osuosl.org/pub/mariadb/repo/10.0/ubuntu precise main deb-src http://ftp.osuosl.org/pub/mariadb/repo/10.0/ubuntu precise main

  1. Refresh your system

sudo apt-get update

  1. And finally install MariaDB

sudo apt-get install mariadb-server

I got this error as the installation was being executed:

160814 12:48:52 [Note] Plugin 'FEEDBACK' is disabled.
160814 12:48:52 [Note] InnoDB: FTS optimize thread exiting.
160814 12:48:52 [Note] InnoDB: Starting shutdown...
160814 12:48:54 [Note] InnoDB: Shutdown completed; log sequence number 1618682
 * Starting MariaDB database server mysqld                               [fail] 
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mariadb-server-10.0 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mariadb-server:
 mariadb-server depends on mariadb-server-10.0 (= 10.0.26+maria-1~precise); however:
  Package mariadb-server-10.0 is not configured yet.

dpkg: error processing package mariadb-server (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                          Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
 mariadb-server-10.0
 mariadb-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have purged removed mysql that I was using earlier but can't fix this. Tried Googling for similar fixes but can not solve mine. Anyone?

0

I recently installed MariaDB. MariaDB is working now, but it was frustrating as it seemed that some obscure step was either "overlooked" by me or otherwise "missing". Unfortunately, I can't provide an answer beyond starting over.

There are a variety of websites which provide a step by step description for installing MariaDB. Surprisingly, using the MariaDB website for installing MariaDB did not go well for me. Maybe you will have better luck

If I remember correctly, this website (linuxbabe.com) Install Apache, MariaDB and PHP7 (LAMP Stack) on Ubuntu 16.04 LTS provided the most complete advice.

An additional website (which I don't believe that I used) by unixmen: How To Install LAMP Stack On Ubuntu 16.04

Prior to attempting again, make sure that all vestiges of PHP 5, Appache, PHPmyAdmin, and MySQL or MariaDB have been purged. (PHP 7 is now the default version.) Additionally, avoid (as part of an initial install) adding the Launchpad repositories for MariaDB and PHP7. Once things work, you may want to add these repositories.

Also there is the usual advice, of backing-up and MySQL and/or MariaDB databases that you may have through mysqldump

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.