0

After performing a clean install of Ubuntu 16.04, my WiFi is trying to connect when disabled. My router WiFi is disabled so my system is hard wired via the ethernet connection. So I don't need the WiFi unless I'm out and about. Both the WiFi and the ethernet operate and connect just fine so there is no problem with the actual connectivity. The hardware works.

However, with the wired ethernet connected, I disable the WiFi via the network indicator in the panel. After the Upgrade, while disabled the WiFi still continues to seek a connection, which because of the router and my location, it can barely detect. So I get constant notifications that I don't have a connection, then I do, then don't, etc.

What could be happening such that with 14.04 the WiFi was disabled when disabled but now with 16.04 disabled is not disabled although it says it's disabled. There's no hardware switch to enable or disable the WiFi and the keyboard function toggle has never worked. It's just permanently "on" and does nothing which is fine with me.

I have an HP ENVY 17 Laptop and the wireless device is an Intel Dual-Band Wireless 3160 (rev 83).

My networking info is are as follows:

lspci

01:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev 83)
    DeviceName:  
    Subsystem: Intel Corporation Dual Band Wireless-AC 3160 [8086:0070]

09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. 
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)

    DeviceName: Hanksville Gbe Lan Connection
    Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1965]

lsusb

Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 174c:55aa ASMedia Technology Inc. ASM1051E SATA 6Gb/s bridge, ASM1053E SATA 6Gb/s bridge, ASM1153 SATA 3Gb/s bridge
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 05c8:036e Cheng Uei Precision Industry Co., Ltd (Foxlink) Webcam
Bus 002 Device 003: ID 8087:07dc Intel Corp. 
Bus 002 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 006: ID 138a:0050 Validity Sensors, Inc. Swipe Fingerprint Sensor
Bus 002 Device 005: ID 0eef:a80f D-WAV Scientific Co., Ltd 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

rfkill

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

1: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

ifconfig

eth0      Link encap:Ethernet  HWaddr <MAC 'eth0' [IF1]>
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::5461:abea:fced:c913/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7858 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6426 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7406246 (7.4 MB)  TX bytes:883972 (883.9 KB)

wlan0     Link encap:Ethernet  HWaddr <MAC 'wlan0' [IF2]>
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:226 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1087 (1.0 KB)  TX bytes:41881 (41.8 KB)

iwconfig

lo        no wireless extensions.
eth0      no wireless extensions.
wlan0     IEEE 802.11abgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off  
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

Thanks.

0

If "fn+f12" isnt working it might be worth asking HP how you can fix that? Might be a simpler process?

Other wise you might need to use a work around, I found the answers and links here to be helpful:

How to switch off wifi on startup or from the console

The only issue here is you'll need to undo it when you want to use the Wifi again... good luck!

| improve this answer | |
  • Thanks Dreadlocked Sp4rtn. It's a work around but not really getting to the heart of the issue. I know how to turn it on and off. It's still seeking WHEN it's turned OFF. Which means that no matter what I do I can't seem to actually turn it off. That's a different issue. However it seems to have stopped after the last update. SO who knows what it was. Thanks anyway. – Exomancer Aug 19 '16 at 5:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.