1

So I have recently reinstalled Ubuntu (16.04.1 LTS) after a while of not using it. I have come across an issue with Wifi connections. I can connect to a Wired network but am unable to connect to wifi and have no option for "connect wireless Network" in the network tab :( I have had a brows through the forums and this seems to be a common issue, unfortunately none of the work-arounds seem to help. I think its probably a driver issue, so if anyone knows of a driver for my hardware then that would be sweet, other wise any solution would obviously be helpful :).

lspci:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01)
02:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
03:00.0 Network controller: MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter
04:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 840M] (rev a2)

rfkill list all:

0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

Not sure if all thats overly helpful, so let me know if there is something else I can help with..

EDIT!!!

I found an answer that seemed to help alot of other people:

sudo apt-get install git dkms build-essential
git clone https://github.com/neurobin/MT7630E.git
cd MT7630E/
sudo make dkms

I ran this and it told me that the driver was successfully installed! I thought YAY!! but still no Wireless Network option and when I unplug the Ethernet cable, it doesn't auto search for Wifi :(

Hope the extra info helps me find an answer..

  • Disable Secure Boot in BIOS. – Pilot6 Aug 14 '16 at 7:57
  • You will see what happens if you run sudo modprobe mt7630e. – Pilot6 Aug 14 '16 at 7:58
  • OMG!!! I freaking love you hahahhaha.. I disabled secure boot in the Bios and when the laptop came back on I had the Wifi Options in the networking tab! it is now working just fine! thankyou so so much!!!! – Dreadlocked Sp4rtn Aug 14 '16 at 9:52
  • @Pilot6 could this effect my ability to use Wifi on the Windows 10 partition? – Dreadlocked Sp4rtn Aug 15 '16 at 0:46
  • It is not related to Windows. – Pilot6 Aug 15 '16 at 9:28
1

Disabling "secure boot" in the bios worked for me! after months I have such an easy answer!

step1: restart computer and enter Bios by pressing F2 or F11 or what ever it is for your computer manufacturer.

step2: go to Boot security, and select safe boot. disable it!

step3: continue with start up and enjoy Wifi!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.