8

After a botched upgrade from Ubuntu 14.04 to Ubuntu 16.04 I had to wipe my system and start all over. This time I decided to go with a much less CPU intensive desktop environment and installed Lubuntu 16.04-1.

My problem: when I run Steam from the menu shortcut it acts like it is doing nothing. However it does show up in the task manager. If I just type steam in the terminal I get the following.

michael@michael-HP-Pavilion-dm1-Notebook-PC:~$ steam
Running Steam on ubuntu 16.04 64-bit
STEAM_RUNTIME is enabled automatically
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
/bin/bash: /home/michael/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /bin/bash)
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
awk: /home/michael/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /lib/x86_64-linux-gnu/libreadline.so.6)
Installing breakpad exception handler for appid(steam)/version(1468023329)
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Then nothing happens including steam doesn't show up in the task manager. Now I did find the command.

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam

This does run Steam but it is not a real solution in my eyes. How can I fix it?

4
  • 1
    If this issue isn't already reported on the Steam-for-Linux github, then it may be worth reporting it. – David your friend Sep 2 '16 at 8:57
  • We have reasons to believe your question is more generally applicable to Ubuntu and its official flavors, so I am going to change Lubuntu back to Ubuntu in the title. – edwinksl Sep 7 '16 at 19:09
  • Ok as long as Lubuntu users know that It was a Lubuntu user that had the problem. Thank you – Michael Scholler Sep 7 '16 at 19:14
  • @MichaelScholler Yeah, they would. I kept the Lubuntu part in the body of the post intact. – edwinksl Sep 7 '16 at 19:19
8

Since you have a command (LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam) to launch it correctly, modify the .desktop file to fix the menu icon so that clicking it runs that command. Do:

cd /usr/share/applications

and then type ls to find the .desktop file for Steam. Here I'm assuming it's called steam.desktop, so check that, and correct the commands below if necessary. Make a backup copy

sudo cp steam.desktop steam-bak

(restore the backup if needed by doing mv steam-bak steam.desktop) edit the original file:

sudo nano steam.desktop

find the first line that starts Exec= (you can use ctrl+w to search in nano) and edit the line so it says:

Exec=bash -c "LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam"

Save the file and exit (ctrl+o then enter then ctrl+x)

Now click the steam icon in the menu to launch

Note to others: if the command LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam does not work for you, try changing DISPLAY=:0 to match your environment. First do echo $DISPLAY and if the output is :0.0, then instead of DISPLAY=:0 in the steam launch command, put DISPLAY=:0.0


Another possible fix: check System Settings > Software & Updates > Additional Drivers and enable the latest proprietary drivers (suggestion from a comment on another post that apparently worked for the OP of that post)


The errors are caused by outdated drivers and libraries bundled with Steam. This can be fixed by disabling them, so that Steam uses system files instead (this is why setting LD_PRELOAD works). You could disable the file(s) throwing errors by renaming them:

mv /home/$USER/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5{,.disabled} 

(there may be several libraries you need to do this to, and you may need to repeat after any updates/resyncing) In any case, it's not a problem with your system, but with Steam.

For comprehensive information see:
Epic Arch wiki post on troubleshooting Steam

3
  • 2
    That was the answer I was looking for. Since I have this started do you see anything else that should be fixed? I see those errors and missing drivers ... do you think this is a problem and /or is it something i should fix or be worried about? – Michael Scholler Aug 14 '16 at 14:05
  • 1
    ah yes... here's the fix to get rid of those errors on Arch forum which may work. The drivers are outdated and system ones need to be used instead. Presumably that is why setting LD_PRELOAD fixes the problem. I will edit my answer... – Zanna Aug 14 '16 at 14:41
  • 1
    You are on a roll. I wish I would of tried this a week ago. – Michael Scholler Aug 14 '16 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.