0

I know this is not a new issue, and that there are countless threads out there(most notably this one) that aim to solve the exact problem I am having. I have followed many of them(including the one linked) to the tee, but unfortunately none of them have worked for me.

I am working on a Lenovo Y50-70. originally maybe a year ago I installed 14.04 on this machine and after a lot of hacking around I eventually got the wifi working, but a recent kernel update wrecked part of my system and I was forced to reinstall. Upon reinstalling I have not been able to get my wifi working after 4-5 days of scouring the forums for solutions. The OS doesn't even recognize that I have wifi.

To generate useful information I used the script from an answer to this question. This information can be found here.

As requested by Pilot, the output of

lspci -knn | grep Net -A2

is

08:00.0 Network controller [0280]: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
Subsystem: Lenovo Device [17aa:0623]
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)

The terminal output of rfkill list all is

0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: ideapad_bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

and the terminal output of sudo modprobe wl is

modprobe: ERROR: could not insert 'wl': Required key not available

marked as duplicate by Android Dev, Pilot6, chili555 wireless Aug 13 '16 at 18:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Disable Secure Boot in BIOS. – Pilot6 Aug 13 '16 at 17:49
  • @Pilot6 I have already disabled secure boot. It had no effect. – jlack Aug 13 '16 at 18:00
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Aug 13 '16 at 18:07
  • What is the exact result of the terminal commands: rfkill list all and also: sudo modprobe wl? – chili555 Aug 13 '16 at 18:15
  • Secure Boot is enabled. You probably disabled something else. – Pilot6 Aug 13 '16 at 18:39