How do I install Ubuntu 11.10 and MythTV client on my Lenovo S12 (Intel Atom) laptop and use it using WiFi?

up vote 4 down vote accepted

I did this because the upgrade from 11.04 bricked the laptop. Note that the partitions on the Lenovo standard disk were already in place for this installation. Also note that my LAN is setup for fixed IP addresses.

  1. Downloaded and burned 11.10 x86 Desktop Ubuntu CD
  2. Connected the power supply cord, LAN wire and the external DVD USB drive.
  3. Ran Windows XP and made sure performance level "Performance" was set and "Wireless" was enabled.
  4. Booted S12 from CD
  5. Disabled Networking from icon on upper left panel icon
  6. Edited Connections… "Wired connection 1" ⋯ Set IP address, accepted default netmask and set gateway. Also set DNS server. Good idea to check "Connection Information" here to verify everything's O.K.
  7. Selected Install Ubuntu from the initial "Install" window
  8. Verified the three items were checked (required disk space available, plugged into a power source, & connected to the Internet)
  9. Selected Download updates while installing and third party software.
  10. Hit Continue…
  11. At wireless selected don't want to connect…WiFi…now. Continue…
  12. At Installation type, selected Something else. Continue…
  13. At partition tale, selected the ext4 Linux partition, set the mount point as "/", and marked for formatting. Here I selected the main disk (/sda) for installing the boot manager. Continue…
  14. Selected or verified my Time zone. Continue…
  15. Selected my keyboard layout. Continue…
  16. Filled in the who are you fields. Make sure password is required to sign in is checked. Continue…
  17. Chose a picture. Continue…
  18. I selected import no accounts. Continue…
  19. Wait as the Install creeps along.
  20. If your screen goes blank, tap the space bar ⋯ apparently the screen saver/power plan does this.
  21. There are several progress bars. The longest was "Installing system", and it was the next to the last one.
  22. Installation Complete window appears, Restart Now…
  23. Wait as it stops,
  24. The screen blanks then the message "…remove…media…close tray…press enter" I just unplugged the USB DVD and hit enter…
  25. It was disheartening but the screen turned Ubuntu Purple-beige and nothing happened, so I help down the power key until it shut down, the pressed it again and the Grub Boot screen appeared. Select Ubuntu… 1.The screen went blank with the little flashing underscore cursor on it and the disk light would occasionally flash. I hit the enter key and eventuality Ubuntu started.
  26. After a somewhat long time the unity desktop appeared.
  27. 11.10, unlike earlier versions, retains the connection information. Check this by checking the network icon on the upper left applet panel.
  28. Here the touch-pad·mouse quit working and I had to reboot. It takes and extremely long time to boot, sometimes requiring several power off/ power on (cold boot).
  29. You can try to get the default network manager to work, but it might not, it didn't on mine for WiFi. UPDATE: For 12.04 Network Manager now works on my laptop. Thanks to: Chris Here's what to do…
    • disconnect your wired Internet connection.
    • input your wireless information into network manager
    • open a terminal (unity dash, top of icon totem, open, and make sure the ruler&pen icon on the bottom is selected, 2nd from left) type in "terminal". Might be a good idea to drag and drop the terminal icon to the totem, it's easy to get rid of later.
    • click to open a terminal, and type in:
    • sudo rmmod acer_wmi && echo "blacklist acer_wmi" >> /etc/modprobe.d/blacklist.conf
    • and hit enter.
    • type in your password as asked.
    • if you have correctly entered your WiFi information and you are near your AP, you should connect immediately
    • if not, see the URL above ⋯ you might need to replace "network manager" with "wicd" ⋯ I did with 11.04.
  30. Update the new 11.10, in the upper left panel applet weird·gear icon is menu with a line about updating. It's the new way to invoke Update Manager.
  31. Your lenovo S12 (intel atom) should now run the new unity Ubuntu. Point your elbow at the ceiling and pat yourself on the back.

Installing Mythbuntu Client 24.1

  1. Open (I urge you not to directly use Ubuntu Software Center for this)
  2. Install Mythbuntu Repos (instructions on web page)
  3. Save the file (in ~/Downloads, the default)
  4. Run the file ⋯ it will update your repositories so that you will get the proper installation sources ⋯ it will start Ubuntu Software Center to do this ⋯ Click Install… You will need your password.
  5. Debconf window will open, select by making sure check mark is in the little box "Would you like to activate…". Forward…
  6. Which version? At the time of writing the current "Stable" version was 24.1, select 0.24.x… Forward…
  7. Read the message, then forward…
  8. Delete the downloaded file.
  9. Install synaptic (unity dash, top of icon totem, open, and make sure the ruler&pen icon on the bottom is selected, 2nd from left) type in "synaptic". Click on the synaptic icon.
  10. Ubuntu Software Center will open and allow you to install synaptic package manager.
  11. Open Synaptic (unity dash, top of icon totem, open, and make sure the ruler&pen icon on the bottom is selected, 2nd from left) type in "Synaptic". Might be a good idea to drag and drop the terminal icon to the totem, it's easy to get rid of later.
  12. Run synaptic, read the intro, and close the intro window.
  13. Type in mythbuntu-control-centre in the Quick filter text box, and then select it "Mark for installation" by clicking on the box next to it's name.
  14. Marvel at the additional to be installed items, then select "✔Mark"…
  15. At the top of the synaptic window click on the "✔ Apply" button.
  16. Marvel at the amount of stuff to be installed, the click on "Apply".
  17. When finished, close finished window and synaptic.
  18. Open mythbuntu-control-centre (unity dash, top of icon totem, open, and make sure the ruler&pen icon on the bottom is selected, 2nd from left) type in "mythbuntu". Might be a good idea to drag and drop the mythbuntu-control-centre icon to the totem, it's easy to get rid of later.
  19. You can now configure and install the frontend. Go down the icon totem on the right side of the window and click as needed…
  20. System roles. ✔ No Backend, Desktop Frontend, and Ubuntu Desktop. Apply… & Apply changes… & Password…
  21. MySQL Configuration ⋯ from backend ⋯ Setup > General > Alt-N(ext) > Alt-N(ext) > Stetting Access > Setup PIN code: ~~~~ Input Security key and click "Test Connection", if ✔, then Apply… & Apply… {note: for some inexplicable reason, control centre hung on this, but when I restarted it, it was set properly}
  22. Graphics drivers, When I did this, only the Broadcom wireless driver showed up. I closed without doing anything.
  23. Services. I enabled SSH & Samba. Apply… & Apply…
  24. Repositories. Asked & Answered.
  25. MythExport. Pass, I believe it requires backend on the same system.
  26. Proprietary Codec Support. Check to enable, Apply… & Apply…
  27. System Updates. No action necessary, will be a part of the Ubuntu update mechanism.
  28. Themes and Artwork. For themes, I selected Enable/Update all. Apply… & Apply…
  29. Infrared & Startup behavior and Plugins. Defer until you know more.
  30. Close software centre.
  31. Open mythTV (unity dash, top of icon totem, open, and make sure the ruler&pen icon on the bottom is selected, 2nd from left) type in "mythTV". Might be a good idea to drag and drop the mythTV icon to the totem, it's easy to get rid of later.
  32. Incorrect Group Membership. Fix this by clicking "Yes"…
  33. Log out/end. Do this by clicking "Yes"… For my Lenovo S12, I had to manually restart Ubuntu - and still with the very long restart…/no start/cold boot/reboot/pressing the shift key required
  34. Open mythTV (unity dash, top of icon totem, open, and make sure the ruler&pen icon on the bottom is selected, 2nd from left) type in "mythTV". Might be a good idea to drag and drop the mythTV icon to the terminal, it's easy to get rid of later.
  35. Will open with Select country & language. Do so. then get message with "No", hit "Ok" and arrive at the data base Configuration 1/2 screen. You will need your brackend password, from backend ⋯ Setup > General > Database Configuration 1/2 > Password:~⋯ Enter this
  36. Hit Alt-n to go to the next page. Select "Use custom id…", then enter a custom ID, I use the machine's name.
  37. Hit finish, and MythTV should start up with all default settings.
  38. For the lenovo S12, the first thing you want to do is to set Playback profiles to "Normal". From Setup > TV Settings > Playback > Alt-N(ext) > Alt-N(ext) > Playback Profiles (3/8) : Change Current Video Playback Profile to "Normal". You can fiddle with this setting later.
  39. For the lenovo S12, the second thing is to get the sound going. From Setup > General > Alt-N(ext) > Alt-N(ext) > Alt-N(ext) > Audio System: The top of the screen is a button title "Scan for audio devices", move the highlight there and press the Space bar. Then Tab down to Audio Output Device: and left-right arrow until "ALSA:hw:Card=Intel,DEV=0" is selected. Then Alt-N(ext) until "Finish". Now you should have sound.
  40. You should now have MythTV working nicely on the Lenovo S12

Notes about wireless:

Running Lenovo S12 on wireless is demanding on both power and WiFi connection. Best results will be obtained when running on power and wired connection. I run my S12 on wireless, actually two serial connections with two access points, something that is not easy to achieve. Here

Mythbuntu client-server (in den) <⋯> wireless link 1 <⋯office LAN⋯> wireless link 2 <⋯> Lenovo S12 Ubuntu 11.10

The office LAN is fixed IP behind an Untangle firewall router. There is another MythTV client on Ubuntu 10.10 computer in the office (which has always worked well).


  • Rosewill RNX-G300EX IEEE 802.11b/g PCI Wireless Card on client-server
  • 2 Linksys WRT54GL wireless broadband routers on LAN for link1 and link 2

WRT54GL FirmwareDD-WRT v24-sp2(07/22/09) voip set up to act as an access point.

Note⋯ many people advised this was an unworkable scheme, and in probably most cases it will be.

Solution⋯ Set up DD-WRT with the following Wireless settings…

  • Basic Channel: Different fixed channels at least 4 difference, I use 6 & 11
  • Basic Sensitivity Range (ACK timing): 50
  • MAC filter use filter: Enable, Selected Permit only clients listed to access… Requires adding MAC addresses in "Edit MAC Filter List" This causes the 54GL's to ignore any but the listed MAC address, down side, no "guest" capability.
  • Advanced Basic rate: All
  • Advanced CTS Protection Mode: Off
  • Advanced Frame Burst: Enable
  • Advanced Max associate clients: 4 for client link 2, 1 for client-server link 1
  • Advanced AP isolation: Enable
  • Advanced Preamble: Short
  • Advanced Afterburner: On
  • Advanced Wireless GUI access: Off
  • Other settings: default for supplied firmware.

Why I suspect this worked⋯

The 54GL Access Points's with the firmware's setting are set to handle a multiple client, wide area situation. With these mods I reconfigured them for a small area, few client situation, disabling Advanced WMM probably the most important. In addition, the client mythtv when used all other users of its access point are turned off except for a Skype phone. Also, the client-server is set up to allow other connections though it's LAN connection, and these are used to connect the TV and disc players, not used when client is being used.

Fix found for long boot problem

See this askubuntu question.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.