I've basically settled into Unity, but one constant that is kind of giving me agita is that in LibreOffice Calc (and Writer) ctrl-f does nothing. I can go to edit > find ... and the edit menu even suggests ctrl-f as a keyboard shortcut, but actually typing it doesn't do anything. ctrl-alt-f works fine. The only thing that doesn't work is ctrl-f. I had a really hard time getting settled with Unity (mostly trying to get my old Gnome-do and Compiz settings back) so I spent a lot of time monkeying with the Compiz Settings Manager. But I can't figure out where I would have unset/ overrode this. Plus, it isn't like ctrl-f does something unexpected. It just does nothing.

  • I also have this same problem, having come from OpenOffice (on Ubuntu and Windows). This is a 'feature', that I consider to be an annoying 'bug'. Some users clearly agitated for it. I'll see if there is a simple fix .. – david6 Nov 22 '11 at 2:40
  • 1
    This is clearly a bug which I reproduced as well. The Edit drop menu clearly indicates <Ctrl>F initiates Find. – fragos Nov 22 '11 at 9:21

You need to re-map the Ctrl-F keyboard action to 'Find & Replace'.

NOTE: The dialog box (Tools >> Customize >> Keyboard) is hard to use, and I was unable to find the existing 'quick find' that is currently mapped to Ctrl-F.

After several attempts, I was able to map:

  • Shortcut keys: Ctrl-F - to - Category: 'Edit', Function: 'Find & Replace'
  • Shortcut keys: F3 - to - Category: 'Edit', Function: 'Repeat Search'
  • Shortcut keys: Ctrl-Shift-F - to - ( left blank )

( This clearly needs work, by the LibreOffice maintainers. )

  • 1
    Ctrl-F does appear to be mapped to "Find" in the keyboard, but as @geoffrey noticed, it pops you to a find box in the toolbar that may or may not be visible – Amanda Nov 22 '11 at 23:20
  • The issue (as it affects me) is that 'Ctrl-F' does NOT open the Find & Replace dialog box. As a long term MS Office/OpenOffice user, that is what I expect when my fingers hit 'Ctrl-F'. The simple "find next" function is not as helpful .. – david6 Nov 23 '11 at 0:40
  • I voted this up, but let me say something in defense of LO. I like two things about the search toolbar: 1) it does not get in the way of text when you search (with the f&r box, sometimes the search term is hidden behind the box, or the box jumps all over the screen), 2) it's easy to search quickly both up and down (with the F&R box, you tick a box to search backwards, and sometimes you forget that box is ticked). I tend to use the simple 'search' function much more than find&replace, so I prefer the unobtrusive toolbar. Only negative in my view is that it takes up so much space on the toolbar. – geoffrey Nov 23 '11 at 7:10
  • 1
    Okay, but then don't make ctrl-f go nowhere if the search bar isn't visible. – Amanda Nov 24 '11 at 1:53
  • 1
    +1 - The 'F3' shortcut for "Repeat Search" saved my day. – paercebal Aug 28 '13 at 17:24

Try this: go to View > Toolbars and check 'Find'. This adds a 'Find' dialog on the toolbar. When you click ctrl-f the cursor jumps to that toolbar, then enter the search term, and hit enter, or use the arrows to search up or down.

  • I'm kind of incensed that this worked, but it did. Why? Why hide the find dialog? – Amanda Nov 22 '11 at 23:20
  • 1
    I'm realizing that I'm still not happy, so remapping ctrl-f to find and replace. In calc, ctrl-f doesn't switch focus to the find box so I do 'ctrl-f' and type something and I replace content. Not good. – Amanda Nov 24 '11 at 1:48

Here I found a simple solution: after deleting $HOME/.libreoffice it worked again. Magic.

  • That seems to solve a different problem. ctrl-f is mapped to the toolbar find by default now. If you want to re-map it, doing that explicitly seems like a cleaner fix than killing your whole LibreOffice settings directory. – Amanda Jan 9 '12 at 20:31
  • I agree that deleting the settings is far from convenient. But the search window came back (and I don't see why a user should remap an existing key setting...). The mapping just didn't work, maybe my settings contained the disabling somehow? Anyway... – markusN Jan 13 '12 at 8:44

I don't seem to have enough karma right now to comment after geoffrey's answer.

However, this could help: first I detached ("undocked") the Find toolbar. This seem to prevent it from materializing docked but out of signt.

Then, I noticed that pressing CTRL+F once make the toolbar appear, but not focus it; pressing it a second time does focus it.

Granted, this is a bug and should be fixed; but in the meantime, this workaround proved quite useful.

  • 1
    the solution above does work, buggy as it all is. – Amanda Apr 1 '12 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.