enter image description hereI am running latest version of Ubuntu (16.04) on my machine. Everything is working quite well except that my shortcuts or links are broken to a particular (second internal physical drive) in my machine.

I have read several questions here that generally all have the same answer, IE the drive is not mounted. I don't think this is a mounting issue though. If I go to the exact same folder and create a new (identical link) and place it on my desktop, it works, but if I click on the original old link, it still says it's broken. When I look at the properties for the two links, they are identical (in terms of file path)

The only difference I can see is where it says Type: Link(broken)(inode/symlink) whereas the working link says Type: Link to Folder (inode/directory)

The working link also has Basic/Permissions and Local Network Share tabs, whereas the broken link now only shows Basic/Permissions and Open Wit

Screenshots of working and broken links

enter image description here

this is what I get after a (working) new link or shortcut is put on the desktop, but note, the old one still does not work. Sorry, I don't know how to run this confusing editor, so the broken link is the picture at the top, the working link is the picture at the bottom. If I reboot the machine then the new one will cease to function as well. This is not a mounting issue in my limited opinion, else how can one link work, when the other does not, yet they point to exactly the same location!

This is what the properties look like for a working link: enter image description here

Note the tabs are different to the broken link, yet they are created in exactly the same fashion, but change after reboot.

  • 2
    Run ls -l <shortcut> twice; once when the shortcut is working, and once when it isn't. Then edit the output into your question. – wjandrea Aug 13 '16 at 3:44
  • Excuse my ignorance here, but where, how am I supposed to run that? If I open a terminal window and run it, unsurprisingly it tells me bash: syntax error near unexpected token `newline' The shortcut is on my Ubuntu desktop. – witenitenz Aug 16 '16 at 9:20
  • Replace the part in angle brackets with the file location. In this case, it looks like it's ls -l /home/graham/Desktop/Music. – wjandrea Aug 16 '16 at 14:07
  • I have added the info (albeit confusing) to my original question above. Obviously I have still not resolved this. Frustrating, as Windows has no issues making shortcuts that you can drag and drop at will. – witenitenz Aug 19 '16 at 23:07
  • Note I have been unsuccessful making the original link work again. Once broken, it stays broken. Any new links work as expected, but post reboot, are permanently broken too. In order to get the screenshot at the bottom, I made a new link on the desktop with exactly the same path, but different name (can't have two links with the same name on the desktop, this is expected) – witenitenz Aug 19 '16 at 23:09

This problem is occured because the link which you have created is on the drive which do not mount automatically on startup so first you need to change the mount options for that particular drive which you simply can do by just simply searching the 'Disk' and change the mount options turn off the User Session Default option.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.