2

I recently attempted to update from 14.04 to 16.04, unfortunately my power went out and the computer shutdown breaking my installation, so I reinstalled without formatting.

I figured this would be no problem since I was able to keep the original /home/user file and I could just copy my files onto an external once a working install was running.

Sadly the new install seems to be a bit wonky as well so I am planning to just format and reinstall as soon as I am able to copy my files from the old home folder.

I've gotten as far as running:

sudo ecryptfs-recover-private /home/user

which successfully mounted the old home folder in /tmp after inputting the encryption key, or so it seems.

The problem is that when I try to launch nautilus from the terminal and view the files in the /temp/ecryptfs/xxxx to copy them, it's just the file access-your-private-data.desktop and the README file telling me to run ecryptfs-mount-private. But this always returns:

ERROR: Encrypted private directory is not setup properly

If I open the .desktop file it opens a terminal asking for login password. I enter the password then something opens and closes very rapidly then nothing.

I tried following someone's directions to setup a new user account and make it the new owner of the old /home/user, with the same result.

I have an external hd, a flash drive formated as a liveOS, and even a second comp at the ready.

How can I access my files?

1

I finally did it by following the answers to this question. First, unmount whatever gvfs is. It's apparently causing problems. So for me this looked like:

umount /run/user/1000/gvfs

Now, an important oversight. You need to direct the ecryptfs recovery command not to the /home/user, but to the .Private directory! For whatever reason it says success, but is lying if you point it to the /home/user.

sudo ecryptfs-recover-private /home/.ecryptfs/user/.Private

Now you should have actual success and be able to launch nautilus and access the files

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.