2

Today I decided to set up my own Ubuntu server using an HP laptop from 2011(HP Probook 4330s).

I installed it using a usb stick and during setup I made an internet connection to my wifi. It seemed like the connection worked and I checked my router and it displayed a working wireless connection to this laptop(wireless lamp on laptop also displayed connected).

When installation was finished and the Ubuntu was restarted I didn't have any internet on wireless or cable. The wireless lamp on laptop displayed not connected. My router did not have a connection to my laptop.

I started searching the web and tried several options for getting the internet up and running.

Tried this

Some suggested that there was a driver issue, but I don't believe that is the case since I during setup did have a connection. But what do I know?

Take a look:

Can anyone find out a solution with this?

Here's what I get with commands people usually post.

ifconfig -a 

ifconfig -a

lspci -vvnn

lspci -vvnn

lspci -knn | grep Net -A2

lspci -vnn | grep Net -A2 I did mess around in /etc/network/interfaces etc/network/interfaces

I'm thinking of trying an older version of Ubuntu and see if that works, but It's really annoying that I can't get the internet working. Does anyone have a solution for this?

UPDATE Have tried commands with rfkill, but for some reason rfkill is not installed on my system.

RFKill and lsmod | grep wmi

UPDATE2 Managed to install rfkill through my wired connection and did a rfkill list all that showed that there is a hard block on my wireless card(a physical button on my laptop). But pressing that button doesn't change anything..

anon@ubuntu:~$ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: yes
2: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: yes
2

Do not try an older version of Ubuntu; it won't work there either until you fix the /etc/network/interfaces file.

In your ifconfig you have neither an eth0 nor wlan0 so these lines are meaningless.

Every wireless interface requires the name of the SSID to which you wish to connect as well as the password, assuming the network is encrypted, as it should be.

I suggest you set up /etc/network/interfaces something like:

auto lo
iface lo inet loopback

auto wlo1
iface wlo1 inet static
address 192.168.1.150
netmask 255.255.255.0
gateway 192.168.1.1
wpa-ssid <your_router>
wpa-psk <your_wpa_key>
dns-nameservers 8.8.8.8 192.168.1.1

Be sure to select a static address outside the range used by the DHCP server in the router, switch or other access point. Of course, substitute your details here. I recommend that servers use a static IP address so that you can later find it with ssh and ftp.

Get the system to read and use the changes:

sudo ifdown wlo1 && sudo ifup -v wlo1

Did you connect?

ping -c3 192.168.1.1
ping -c3 www.ubuntu.com

If your wireless is hard-blocked, it is probably because the helper module hp-wmi doesn't properly translate key presses into action; in your case, 'turn on the wireless, please.'

You can remove the module temporarily to see if it helps:

sudo modprobe -r hp-wmi
sudo rfkill unblock all
rfkill list all

If it helps, we can blacklist the module.

Since 16.04.1 is the latest stable kernel version and, presumably, the latest version of hp-wmi, it will do no good to look for a later Ubuntu version. As an off chance, you might try an earlier version, 14.04, to see if hp-wmi works as expected. You should be able to verify that it works or not by running a live session.

Finally, you can try the famous pin 13 trick: http://madwifi-project.org/wiki/UserDocs/MiniPCI#MaskingPin13

If you are thinking of getting a USB wireless device, I can assure you that I have worked on more than a few cases where rfkill also blocked USB wireless.

In any case, I'd suggest that you register and file a bug report against hp-wmi: https://help.ubuntu.com/community/ReportingBugs

10
  • When doing the ifdown/ifup command I got an error at the and saying: "RTNETLINK answers: Operation not possible due to RF-Kill" I'm doing some googling now trying to find answers on this. Seems that you got me on the right path though. More help is much appreciated
    – JoakimE
    Aug 12 '16 at 21:00
  • Some suggests doing "rfkill unblock wifi", but it's not installed so...
    – JoakimE
    Aug 12 '16 at 21:06
  • What does rfkill list all tell us? Also: lsmod | grep wmi
    – chili555
    Aug 12 '16 at 21:13
  • I added a wired network to /etc/network/interfaces (enp37s0), and that works. But I still cannot get the wifi working. I still want this to work.
    – JoakimE
    Aug 12 '16 at 21:27
  • Does pressing the wireless button change the wireless light at all? See page 12 here: h10032.www1.hp.com/ctg/Manual/c03054507.pdf
    – chili555
    Aug 12 '16 at 21:35
1

To complement chili555's answer, I would suggest looking at the output of the dmesg command for warnings or errors thrown by the kernel or the modules responsible of handling your network adapters.

I have personally learned quite a few things about my laptop and fixed otherwise cryptic issues just by examining what dmesg was trying to tell me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.