1

I'm trying to share a folder between my host (ubuntu 15) and my vm (alpine linux). I've been following this article: https://help.ubuntu.com/community/VirtualBox/SharedFolders

I'm not sure what this command means though:

sudo mount -t vboxsf -o uid=$UID,gid=$(id -g) share ~/host

I've tried this:

me@mydevox:~$ sudo mount -t vboxsf -o uid=$UID,gid=$(id -g) ~/Downloads/rethinkdb/ ~/Documents/mysharedfolder

But I get this error back:

mount: unknown filesystem type 'vboxfs'

I've tried both vboxfs and vboxsf

Any suggestions would be apprciated.

EDIT 1

One artifact I found which might help is that when I start the VM (after having installed the guest tools), in the "Devices" menu, instead of giving me a " Install Guest Additions" option, I see a "insert Guest Additions CD image" option. When I select it, nothing happens.

In the set up of the vm, under the "storage" category, I've made sure the iso is the correct one. It's pointing to : /usr/share/virtualbox/VBoxGuestAdditions.iso

which exists.

Could it be because the guest os I've installed doesn't have a gui? My guest os is alpine linux

EDIT 2

I found this : https://www.virtualbox.org/ticket/9558 But I don't know how to manually mount the CD on my guest machine...

  • Specify an existing but empty folder on your system as the mount point. If you want to follow this example exactly, mkdir ~/Documents/mysharedfolder first to create the mount point. (edited to match edits in question). – user4556274 Aug 12 '16 at 17:44
  • @user4556274 thanks. i ended up figuring that part out and so i've changed my question. sorry about that. and thanks – Happydevdays Aug 12 '16 at 17:49
  • given your question has changed :-) and I don't use the product, I'll leave someone else to answer. You can see which filesystems your kernel can mount with cat /proc/filesystems. If you don't see vboxfs in the list, it would presumably mean you haven't installed the VirtualBox guest tools correctly (or at all). – user4556274 Aug 12 '16 at 18:00
  • @user4556274. thanks! that's a good command to know about. I have installed the guest tools ... and I have the iso mounted for the vm. When i start the VM up though, I'm noticing that in the "Devices" menu, it has the option "insert guest tools cd" ... vs "install". – Happydevdays Aug 12 '16 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.