13

There is no launcher, menu bar and dash on my ubuntu 16.04. Happened when I logged in. Didn't do any changes to the system on my previous session. 16.04 has been working fine for me since it was released.

I know this has been answered before and I tried these answers:

Launcher, menubar and window borders disappeared in Ubuntu 16.04

Launcher disappeared

I first did a reset of .config/dconf but that didn't do it.

Edit:

Reinstalled Unity - no success
Disabled/Enabled Unity-plugin in Compiz-config-settings manager - no success

The icon for the Unity plugin in Compiz-config-settings manager looks like a question mark. Doesn't seem to look like that when I google images of the settings manager. Guess something is wrong with the plugin.

0
21

I had the same problem. Out of the blue the launcher, menu bar and window had disappeared. Other users of the same installation had no problems, so it had to be a user configuration problem. I tried several of the mentioned solutions, but only this one worked:

mv ~/.cache/compizconfig-1 ~/.cache/compizconfig-renamed
shutdown -r 0

After that the controls came back after logging in and I resized the buttons in the launcher again.

6
  • it helped me! thx Mar 13 '18 at 13:20
  • This saved my day. Any idea why this has happened in the first place??? Any update cause this???
    – Thush-Fdo
    Mar 14 '18 at 8:52
  • 2
    Can confirm that none of the solutions in this thread, this one, or this one worked, but this solution did.
    – tparker
    Mar 14 '18 at 17:15
  • Thanks,its working perfect and prevent us to format the system :)
    – akgola
    Feb 28 '19 at 6:39
  • This fixed it for me too. May 20 '19 at 23:51
11

Have you tried reinstalling Unity?

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity
sudo reboot
4
  • 1
    Tried that without success. I also enabled/disabled the unity plugin compiz-config-settings-manager without sucess.
    – riwid
    Aug 15 '16 at 10:41
  • Seems that the unity plugin doesn't work. The unity plugin icon in compiz-config settings manager looks like a question mark. When I write unity in a terminal I can see the menubar flickering on top before it dissapears again. (The above of-course means that I managed to install compiz-config-settings manager).
    – riwid
    Aug 15 '16 at 11:35
  • 1
    Win's method worked for me
    – Pototo
    Apr 19 '19 at 20:45
  • sudo apt-get update worked for me. May 3 '19 at 6:41
1

compiz-settings may do some desktop launcher disappearance with or without changing system settings, specially when you enable some cube engines that requires to disable some general requirements for your desktop environment.

meaning maybe there is no error , just edited configurations.

note : sometimes it happens when you suddenly shutdown your system.

  1. can you provide us with your xorg and xserver in the user home log ?
  2. run Ubuntu 16.04 terminal and run compiz-settings :

right-click on desktop + open terminal

then write in terminal :

ccsm

try to disable what you did and let us know please.

hints : in ccsms goto :

  1. desktop -> enable Ubuntu unity plugins
  2. uncategorized -> enable unity grab handles

Not the answer you're looking for? Browse other questions tagged or ask your own question.