5

I receive error emails from ZFS telling me that ZFS has detected an io error, but, the details listed do not show any checksum, read or write errors. A zpool status does not show any errors and a scrub does not report any errors.

Email content:

ZFS has detected an io error: 

eid: 7 
class: io 
host: ubuntu 
time: 2016-08-10 18:18:37+0100 
vtype: disk 
vpath: /dev/disk/by-id/ata-WDC_WD30EFRX-68EUZN0_WD-WCC4N7FSX6F9-part1 
vguid: 0xFE98965C2E168896 
cksum: 0 
read: 0 
write: 0 
pool: unas 

The zpool is made up of two mirrors:

NAME                                           STATE     READ WRITE CKSUM
unas                                           ONLINE       0     0     0
  mirror-0                                     ONLINE       0     0     0
    ata-WDC_WD30EFRX-68EUZN0_WD-WCC4N1VUU0LX   ONLINE       0     0     0
    ata-WDC_WD30EFRX-68EUZN0_WD-WCC4N7FSX6F9   ONLINE       0     0     0
  mirror-1                                     ONLINE       0     0     0
    ata-WDC_WD3200AAKX-001CA0_WD-WMAYUW798623  ONLINE       0     0     0
    ata-ST3320418AS_6VM5GXHJ                   ONLINE       0     0     0

errors: No known data errors
1
  • I suggest you run a scrub: zpool scrub unas – Andreas Hasenack Aug 15 '16 at 13:21
0

This could possibly be due to hard drive spin down.

See this answer for details on how to check and adjust your hdd spindown settings. How can I control HDD spin down time?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.