3

Recently, my computer has developed a rather puzzling problem. After I finish an Ubuntu installation, Ubuntu spits out a number of errors seemingly related to bad blocks. These errors cover my screen and require me to forcefully power off my machine.

This error is rather annoying, as the USB appears to be in good condition.

Some errors include (but are not limited to) the following:

  • SQUASHFS error: Superblock in USB, cylinder 3
  • SQUASHFS fatal error, SQUASHFS exited with error code 5

I've already tried the solutions outlined in these questions to no avail. What can I do to remedy this problem?

(I have a UEFI Toshiba Laptop. The SMART test said that the drive was OK. I also have ran memtest86. No fault there)

EDIT: I used KazWolfe's answer and found out there was exeeding number of hashes. So I got a new iso and this time i installed the 16.10 iso.

But it still comes up with spamming SQUASHFS errors.

What is happening!!!

  • 2
    Have you seen this? Looks related but perhaps not exactly the same bugs.launchpad.net/ubuntu/+source/linux/+bug/172937 add yourself here. – Mark Kirby Aug 23 '16 at 7:09
  • 1
    Thank you for providing "Some errors" Are there other errors or more information that might shed further light on your problem? The questions you say you have tried the solutions don't have any that I can see. Could you provide further information regarding your equipment? Are you running on a UEFI system? have you checked SMART status of the drive? Have you run memtest86? Please edit your question to provide enough information for a serious analysis of your problem. Thank you. – Elder Geek Aug 23 '16 at 22:39
  • 1
    Did you by any chance review help.ubuntu.com/community/SquashfsErrors – Elder Geek Aug 23 '16 at 22:46
  • 2
    FYI in order: Where you obtained your ISO has no bearing on whether it got corrupted during transfer. You say your USB is new and doesn't have bad RAM, that's nice but has nothing to do with whether your system has bad RAM which is what memtest86 tests. The fact that you can duplicate the issue doesn't add anything actionable to the question. One final time I will request that you answer the questions I put to you in the comments which may result in better answers. What you've given us is not what was requested and in no way helps us help you. Thank you for your understanding. – Elder Geek Aug 24 '16 at 19:07
  • 2
    Please provide the requested information, you have logged in and posted since @ElderGeek requested information. You can't complain about not getting answers and then just ignore our requests for information. – Mark Kirby Aug 25 '16 at 11:00
5
+200

This issue is often caused by either a hardware failure with your drive (as suggested by Error 5, which is almost always an I/O error), or a problem with the disk image you are using. More rarely, it can be a memory error, but this seems unlikely in your case.

You can remedy this particular issue by downloading a clean ISO from the official Ubuntu website, and then verifying the MD5 hash of the file using the below command:

 md5sum /path/to/the/ubuntu.iso

You can find the valid MD5 sums for 16.04.1 below, sourced from this file. Be sure that the results from the command you've run and that file (or below) are the exact same.

c94d54942a2954cf852884d656224186 *ubuntu-16.04-desktop-amd64.iso
610c4a399df39a78866f9236b8c658da *ubuntu-16.04-desktop-i386.iso
23e97cd5d4145d4105fbf29878534049 *ubuntu-16.04-server-amd64.img
23e97cd5d4145d4105fbf29878534049 *ubuntu-16.04-server-amd64.iso
494c03028524dff2de5c41a800674692 *ubuntu-16.04-server-i386.img
494c03028524dff2de5c41a800674692 *ubuntu-16.04-server-i386.iso
17643c29e3c4609818f26becf76d29a3 *ubuntu-16.04.1-desktop-amd64.iso
9e4e30c37c99b4e029b4bfc2ee93eec2 *ubuntu-16.04.1-desktop-i386.iso
d2d939ca0e65816790375f6826e4032f *ubuntu-16.04.1-server-amd64.img
d2d939ca0e65816790375f6826e4032f *ubuntu-16.04.1-server-amd64.iso
455206c599c25d6a576ba23ca906741a *ubuntu-16.04.1-server-i386.img
455206c599c25d6a576ba23ca906741a *ubuntu-16.04.1-server-i386.iso

After you've verified that the MD5 hashes are actually EXACTLY as they appear here, you may proceed to actually burn it to a known-good flash drive. You can verify a good flash drive by running the read only check specified in the accepted answer to this question.

Once you're sure that both the ISO and your flash drive work properly, you can use the Ubuntu ISO Tool or just dd to burn the ISO to your flash drive.

  • 1
    Thanks for your answer. Unfortunately I got the ISO from the official Ubuntu website (ucmirror.cantabury.co.nz) and the hash is correct and there are no memory errors (MemTest). Could this a possible USB 3.0 fault? – boomt14 Aug 24 '16 at 3:30
  • @ƎpᴉʇʎXD It would be the fault of the flash drive, not USB 3 – Kaz Wolfe Aug 24 '16 at 3:52
  • 1
    @ƎpᴉʇʎXD Also, I have had at least four dead flash drives right out of the packaging. – Kaz Wolfe Aug 24 '16 at 4:01
  • 1
    One hash was outta value. You can have the tick – boomt14 Aug 24 '16 at 4:07
  • 5
    @ƎpᴉʇʎXD Really? After a meta question and Jorges bounty and you constantly saying iso / usb is not the issue, this turned out to be a bad download, that should of been the first thing you checked, what a waste of a bounty :( – Mark Kirby Aug 24 '16 at 10:31
4

This can be caused by a number of problems (the most common being bad RAM which you can test with memtest86) followed by a connectivity problem (board level or USB harness in your case) or possibly a corrupt ISO

Temporary Workarounds Some users have reported that adding the ide=nodma or acpi=off allowed them to work around this issue (which proved to be bad memory modules). You might want to give that a try.

Successful boot was achieved by adding all_generic_ide to the grub boot line for the live CD.

You can add those lines to the grub entry, either in the grub.conf file or either entering letter 'e' on the grub menu and after editing Control+x to boot:

Add to the grub line:

all_generic_ide pci=nommconf Add to the kernel line:

ide=nodma acpi=off More information about the problem in grub can be found here: https://bugs.launchpad.net/wubi/+bug/608941

If you have confirmed that it's not a hardware problem you will want to subscribe to this long standing bug

If anything in this answer is unclear please comment and I will attempt to clarify.

Source: https://help.ubuntu.com/community/SquashfsErrors

  • Hello. Thanks for your answer. This is not a ISO fault, nor BAD RAM nor a connectivity problem (USB 3.0). – boomt14 Aug 24 '16 at 3:28
  • 1
    This was an iso issue, have a +1 – Mark Kirby Aug 24 '16 at 10:35
  • 1
    Yeah from me too – Zanna Aug 24 '16 at 10:47
  • @ƎpᴉʇʎXD I suggest the you subscribe to the bug report listed in that case. – Elder Geek Aug 24 '16 at 19:00
2

Actually, you are mistake on one point:

It is quite the annoying, there is no SUPER BLOCKS on my USB

There certainly are superblocks on your USB, because it contains a filesystem. Superblocks are metadata structures within file systems, and as such you can bet on the fact that squashfs has one or more superblocks.

First thing to try, is take another USB disk, make a bootable USB from it and see whether the issue continues to exist. That would exclude that your USB disk is actually - after all - having problems. You can't just deduce "it works on Windows hence it's good", because the defective sectors might just never be accessed using Windows, especially not if they are being used by a file that you won't access.

Here is some reading on what super blocks are.

  • "there is no SUPER BLOCKS on my USB" – boomt14 Aug 23 '16 at 3:58
  • There is no superblocks on my USB. It is perfectly fine. – boomt14 Aug 23 '16 at 3:58
  • 5
    @ƎpᴉʇʎXD Your usb must have a superblock, here is a definition "A superblock is a record of the characteristics of a filesystem, including its size, the block size, the empty and the filled blocks and their respective counts, the size and location of the inode tables, the disk block map and usage information, and the size of the block groups." If it has no superblocks, where is it keeping this data? – Mark Kirby Aug 23 '16 at 7:07
  • 2
    Please, let's first make sure that your USB disk is not the cause. Find another one, and try to create a LiveUSB with it. See if it works. You have to eliminate all possible causes when analysing a problem. In this case, the hardware is likely to be defective. – jawtheshark Aug 23 '16 at 7:16
  • @jawtheshark The usb is rather new and it could be a usb 3.0 problem – boomt14 Aug 24 '16 at 3:33
0

You said after Ubuntu installation you have to power off your machine but never said what happens after you unplug the USB power the machine back on. Also you didn't mention your Toshiba model number which might have specific glitches. BIOS version number could be important too.

You said you are using UEFI, but have you tried CSM? In BIOS turn off Secure Boot and then change UEFI to CSM.

Secondly, USB 3 support isn't native in BIOS on some machines and drivers are loaded during boot by the OS. You could try a USB 2 boot stick instead of your current USB 3 boot stick.

Lastly, some Toshiba users claim for UEFI based USB booting Rufus Windows Version should be used to format the USB and set partition type to "GPT partition scheme only for UEFI".

Not knowing your machine and seeing what's going on that's all that comes to mind.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.