1

I tried to mount a drive, but it fails on reboot, and I have to press S to skip so I can log in. Is there a certain way I should add it to the fstab? Here is what I see when I type blkid

/dev/sdb1: UUID="cf71fa06-d1db-47e1-893d-c0069aa1f77f" SEC_TYPE="ext2" TYPE="ext3"

I can mount it using the old way and it works fine

/dev/sdb1    /media/PLEXdrive   ext3    defaults     0        2

It used to work, but I formatted the drive that was 12.04 and installed 14.04.5 server. Not sure what im missing here. The drive I am mounting is a data drive with all my PLEX media server videos and movies, etc

  • 1
    UUID="cf71fa06-d1db-47e1-893d-c0069aa1f77f" /media/PLEXdrive ext4 defaults 0 2 should work. Change ext4 to ext3 if you're running an older version of Ubuntu. – heynnema Aug 12 '16 at 0:24
  • that worked. Did it work because I left the quotes around the UUID? I dont recall letting the quotes the last time I mounted a drive. – Gary Aug 12 '16 at 0:36
  • eh... actually, you could leave off the quotes around the UUID. Did you have to change the ext4 to ext3 for Ubuntu 14.04? I forget when they default started using ext4. I'll post as an answer and maybe you can rate/accept it. – heynnema Aug 12 '16 at 0:40
  • I did have to change to ext3. The drive was first installed on ubuntu 12.04 LTS, and I just keep it the way it is and use it now on 14.04.5 LTS. Im not a linux guru, so I dont know if ext4 would work. I could try it and see. I assume that you have to use what is shown when sudo blkid is run. Thanks for your help – Gary Aug 12 '16 at 19:34
  • You can convert ext3 to ext4 if you want to take advantage of its features. – David Foerster Aug 12 '16 at 21:41
3

As above, this should work:

UUID=cf71fa06-d1db-47e1-893d-c0069aa1f77f /media/PLEXdrive ext3 defaults 0 2

Change ext3 to ext4 if you're running a newer version of Ubuntu.

  • Glad you got it going! Cheers, Al – heynnema Aug 12 '16 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.