1

I am running Kodi via XServer from 2-monitor remote conputer. When Kodi starts, it occupies entire 2 monitor are and absolutely useless.

It has a config to run in windowed mode, but how to activate it from command line?

I have edited

~/.kodi/userdata/guisettings.xml

and changed

<screenmode default="true">DESKTOP</screenmode>

to

<screenmode default="true">WINDOW</screenmode>

but it changes back to DESKTOP each run.

How to overcome?

0

Encountered the same issue. Within the section <videoscreen> of file ~/.kodi/userdata/guisettings.xml you have to change this:

<screenmode default="true">DESKTOP</screenmode>

To this:

<screenmode>WINDOW</screenmode>

Start Kodi now and it will be windowed.

0

In Leia it changed a bit. This will fix it as of today.

edit ~/.kodi/userdata/guisettings.xml

change

<setting id="videoscreen.screenmode" default="true">DESKTOP</setting>

to

<setting id="videoscreen.screenmode" default="false">WINDOW</setting>

and you're all set.

0

In addition to(instead of) <setting id="videoscreen.screenmode" default="false">WINDOW</setting>
There are a setting to choose monitor where Kodi can run fullscreen: (it also available in kodi settings GUI)

<setting id="videoscreen.monitor">HDMI-0</setting>

To find monitor name - run xrandr without arguments, it will list all connected and not connected monitors

0

Looks like it moved again a bit. The change is now under

<videoscreen>

in:

~/.kodi/userdata/guisettings.xml

Change

<screenmode default="true">DESKTOP</screenmode>

to:

<screenmode default="false">WINDOW</screenmode>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.