1

I'm trying to install some GNOME Shell Extensions on Ubuntu 16.04 (64bit) from the web site extensions.gnome.org. I'm using Gnome 3.18 with LightDM.

I verified that Firefox has the Gnome Shell Integration plugin enabled, and the extension page loads with the on/off slider correctly displayed.

When I switch the slider to "on", I accept the dialog about installation but then nothing happens. After reloading the page, the slider is still "off". Thus the extension is actually NOT installed and the directory .local/share/gnome-shell/extensions/ remains unchanged.

I read older discussions whereas someone were suggesting to reset GNOME settings to default, as discussed here: How do I reset GNOME to the defaults?, but that did not solve the issue.

0

Have you installed the chrome-gnome-shell package?

From the website:

This extension provides integration with GNOME Shell and the corresponding extensions repository https://extensions.gnome.org You MUST install native connector for this extension to work. [...]

For Ubuntu Linux package is available in the ne0sight/chrome-gnome-shell PPA. To install it, type:

sudo add-apt-repository ppa:ne0sight/chrome-gnome-shell 
sudo apt-get update
sudo apt-get install chrome-gnome-shell
  • Yes, I did install that package. It should not affect Firefox though. Anyway, I could actually install some extension but the one I was trying to install from the beginning (namely LightDM Lock Screen, extensions.gnome.org/extension/910/lightdm-lock-screen) is still not installing – jack008 Mar 14 '17 at 14:35
  • But it does. I have done it in my Firefox and it works now – Juan Gómez Carrillo Mar 14 '17 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.