0

I get (Getting printer information failed) message when trying to print to my (desktop lubuntu 16.04 shared printer) from my (client lubuntu 16.04 laptop). The desktop pc has an HP Deskjet 1050-J410 series printer connected by USB, CUPS & hplip installed but samba has been uninstalled as not using windows. The printer appears in Printer Configuration window automatically, but will not print. hplip is not installed on the client machine. This happens when trying to print from Leafpad, Libreoffice writer & Firefox. when trouble shooting I get run (su -c 'journalctl -u cups.service --since="None" --until="2016-08-11 13:35:24"' > troubleshoot-logs.txt) This displays authentication failure. Any help will be greatly appreciated.

1

Samba or NFS is needed to print to the shared printer. The desktop where printer is attached needs to have samba server enabled as well as password for samba set via sudo smbpasswd -a user

After that the password needs to be set in printer verification dialog on the client machine.

  • Sorry but are you saying I need samba on both server & client machines? How do I set the password in printer verification dialog please. – Marty Aug 12 '16 at 16:46
  • So far I have been using help.ubuntu.com/community/NetworkPrintingWithUbuntu which seems to indicate that samba is only needed for windows. Installed samba to desktop, tried to enable & set P/W via sudo smbpasswd -a user. I can not understand how to do this. – Marty Aug 12 '16 at 18:05
  • sudo smbpasswd a- yourusername and it will ask for password to be set. Samba works reliably for printer share, the server machine doesn't even need to be logged in for clients to access the printer. Make sure you have the authentication set with yourusername and the samba password you selected in client printer properties. – Arup Roy Chowdhury Aug 13 '16 at 2:00
  • sudo smbpasswd a- username brings up options but nothing about setting a password. I still don't no if I need samba on both server & client machines?? – Marty Aug 13 '16 at 12:05
  • I think I have sorted out setting the password using forums.linuxmint.com/viewtopic.php?t=61606 I have no idea how to set up the authentication on the client. Do I need samba installed on the client & how should I set that up? Thanks for your help so far. – Marty Aug 13 '16 at 14:34
0

Got it to print at last it was the firewall on the print server. Tried sudo ufw allow 139/tcp sudo ufw allow 445/tcp sudo ufw allow 137/udp sudo ufw allow 138/udp iptables -A INPUT -p tcp --dport 631 -j ACCEPT sudo ufw allow 5353/udp sudo ufw allow mdns Non of which worked, so I have disabled the firewall.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.