2

I'm trying to install Oibafs PPA for Mesa on my wifes computer. We are both running 15.10 and on my computer it worked without any issue but on hers it seems like it's gotten stuck on software rendering. On her computer glxinfo tells me:

glxinfo | grep OpenGL renderer
OpenGL renderer string: Gallium 0.4 on llvmpipe

While on mine:

OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN (DRM 2.43.0, LLVM 3.6.2)

We used fglrx before and I have tried purging them using the instructions here. Our issue seems similar to Getting rid of llvmpipe. Installing open source drivers correctly but using the suggested method to install Oibaf there didn't work:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:oibaf/graphics-drivers
sudo reboot

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get upgrade
sudo reboot

The Xorg.0.log though seems to claim that there still are remnants of fgrlx hanging around:

[    44.489] (==) Matched fglrx as autoconfigured driver 0
[    44.489] (==) Matched ati as autoconfigured driver 1
[    44.489] (==) Matched modesetting as autoconfigured driver 2
[    44.489] (==) Matched fbdev as autoconfigured driver 3
[    44.489] (==) Matched vesa as autoconfigured driver 4
[    44.489] (==) Assigned the driver to the xf86ConfigLayout
[    44.489] (II) LoadModule: "fglrx"
[    44.489] (WW) Warning, couldn't open module fglrx
[    44.489] (II) UnloadModule: "fglrx"
[    44.489] (II) Unloading fglrx
[    44.489] (EE) Failed to load module "fglrx" (module does not exist, 0)

I have just about given up so I really need some suggestions what could be wrong. Does Oibaf no longer work for 15.10 so I should upgrade to 16.04? That's a transition I'm thinking of doing anyway but I would prefer to have the graphics drivers in order before I do a change that stops me from going back to fgrlx.

Edit: I decided to upgrade to 16.04 and after that it actually looked like Oibaf was installed. A couple of packaged where for some reason held back but I forced them through with

sudo apt-get dist-upgrade

I rebooted but glxinfo still showed llvmpipe. I tried following instructions here as per suggestion from the comment below but it didn't help.

  • Oibaf worked well for be through 15.10 and now on 16.04. Try removing fglrx as described in this post – Charles Green Aug 11 '16 at 14:47
  • Thank you for the reply. I tried it but no joy. sudo dpkg-reconfigure xserver-xorg was the only step I hadn't tried but it didn't seem to matter. I decided to upgrade to 16.04 but no luck. – Skadlig Aug 11 '16 at 18:32
3

With help from bridgman on the Phoronix Forums I managed to figure out that the problem was the kernel

[    32.211] (II) [KMS] drm report modesetting isn't supported.
[    32.211] (EE) open /dev/dri/card0: No such file or directory[/CODE]

"nomodeset" was set in grub stopping the kernel from figuring it out for it self. This is what I did:

sudo vi /etc/default/grub

Find the line "GRUB_CMDLINE_LINUX_DEFAULT" remove nomodeset and save.
Update grub and reboot.

sudo update-grub
sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.