I have freshly installed Ubuntu 14.04 onto an Asus X554S laptop. When I click the restart of shutdown button, it starts shutting down, but after a bit of loading (showing that purple loading screen) it just simply stops and never finishes shutting down. I have to manually turn the computer off, after which if I want to turn it on again, it doesn't reboot, only if I repeat the process (turn off then on) once more.

I have tried the following:

  • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force" (no result)
  • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off" (no result)
  • removed the quiet splash part so I could see what's happening (I'm not sure if I did that right), but the plymouth screen still appeared (before anyone asks, I did update-grub after each attempt)
  • blacklist wistron_btns (no result)
  • sudo poweroff (yields the same result; well, more bulbs light up on the plymouth screen, but I don't think that's progress)
  • Cairo Dock is not installed (I remember it used to cause similar problems for some people)
  • connects to wireless network perfectly and has internet access (so my guess is it's not a network issue, although I could be wrong)
  • I have had no graphic issues until I removed "quiet splash" from GRUB, then upon booting it showed text, but the numbers and letters were unintelligible (maybe an issue with the Nvidia driver?)

What else can I do?

EDIT: In the process, for reasons beyond my comprehension, the touchpad stopped working. Now neither xinput --list nor cat /proc/bus/input/devices shows any signs of it. I did install a pack of updates recommended by the system, though (which might have solved my initial problem without my knowing, see below).

Nevertheless, I did update my nvidia driver using sudo apt install nvidia-340 -y, after which it did shut down properly. Restarting the machine, however, proved troublesome, as bbswitch found no discrete VGA device. Not even my mouse was usable. So, I used sudo apt purge nvidia*, after which my computer did reboot. I tried nvidia-352 just to see what happens, but the results were the same: successful shutdown, no discrete VGA device. So I purged that as well.

Now the situation is rather peculiar as I find no graphical errors, the system shuts down and powers off properly, yet my touchpad is still undetected. I guess that deserves a question of its own. I'll still leave this one unsolved for now until I'm absolutely sure the problem doesn't creep back in somehow.

| improve this question | | | | |
  • I had the same problem with 16.04. Try installing Nvidia driver. It solved my problem. – Dante Aug 10 '16 at 16:54
  • Tried that; edited post with results. – Sándor Gebei Aug 11 '16 at 10:59
  • I cannot find your laptop in Asus website, but if it is new (or even it is not), maybe there is a problem with BIOS. Try update it and set it to default. In addition why don't you try installing 16.04 and see what happens? – Dante Aug 11 '16 at 17:38

That's very odd. I've heard about this issue before, but assumed it was fixed in the newer versions of Ubuntu.

Can you give the following command a shot and let me know what happens?

sudo init 0

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.