1

Now that Ubuntu 14.04.5 is available with 16.04 Kernel, which virtualbox package should I download for ubuntu 14.04.5?

Should I download the package compiled for 14.04 (trusty) or 16.04 (xenial)?

Or is it independent of kernel version and depends more on the versions of GCC, Python and other system libraries specific to a particular ubuntu release?

1

The deb package of VirtualBox 5.1.2 for Ubuntu 16.04 depends on packages that are not in trusty's repository.

$ aptitude show virtualbox-5.1
Package: virtualbox-5.1                  
Version: 5.1.2-108956~Ubuntu~xenial
State: installed
Automatically installed: no
Priority: optional
Section: contrib/misc
Maintainer: Oracle Corporation <info@virtualbox.org>
Architecture: amd64
Uncompressed Size: 156 M
Depends: libc6 (>= 2.15), libcurl3 (>= 7.16.2), libdevmapper1.02.1 (>= 2:1.02.97), libgcc1 (>= 1:3.0), libgl1-mesa-glx | libgl1, libpng12-0 (>=
         1.2.13-4), libpython2.7 (>= 2.7), libqt5core5a (>= 5.5.0), libqt5gui5 (>= 5.3.0) | libqt5gui5-gles (>= 5.3.0), libqt5opengl5 (>=
         5.0.2) | libqt5opengl5-gles (>= 5.0.2), libqt5printsupport5 (>= 5.0.2), libqt5widgets5 (>= 5.2.0), libqt5x11extras5 (>= 5.1.0),
         libsdl1.2debian (>= 1.2.11), libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 5.2), libvpx3 (>= 1.5.0), libx11-6, libxcb1, libxcursor1 (>
         1.1.2), libxext6, libxinerama1, libxml2 (>= 2.7.4), libxmu6, libxt6, zlib1g (>= 1:1.1.4), psmisc, adduser
PreDepends: debconf (>= 1.1) | debconf-2.0
Recommends: libasound2, libpulse0, libsdl-ttf2.0-0, kmod | kldutils | module-init-tools, linux-headers-generic | linux-headers-generic-pae |
            linux-headers-686-pae | linux-headers-amd64 | linux-headers-2.6-686 | linux-headers-2.6-amd64 | linux-headers, linux-image, gcc,
            make | build-essential | dpkg-dev, binutils, pdf-viewer, libgl1
Conflicts: virtualbox, virtualbox:i386, virtualbox-guest-additions-iso, virtualbox-guest-additions-iso:i386, virtualbox-ose,
           virtualbox-5.1:i386
Replaces: virtualbox, virtualbox:i386
Provides: virtualbox
Description: Oracle VM VirtualBox
 VirtualBox is a powerful PC virtualization solution allowing you to run a wide range of PC operating systems on your Linux system. This
 includes Windows, Linux, FreeBSD, DOS, OpenBSD and others. VirtualBox comes with a broad feature set and excellent performance, making it the
 premier virtualization software solution on the market.

From the output above you can see that it depends on libdevmapper1.02.1 >= 2:1.02.97 but the available package for trusty is older than that (2:1.02.77). The same for libstdc++6. Required version is >= 5.2 but available version is 4.8.4. There's also libvpx3, that is not available at all for trusty.

VirtualBox package for Ubuntu 16.04 won't install on Ubuntu 14.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.