I was using 14.04 LTS on my machine. When I got the notification that I can upgrade to 16.04.1 LTS, I downloaded the iso in order to get a clean reinstall. I have / on sda1 and /home on sda2 (seperate partitions). While installing 16.04.1, I chose to format sda1 and use it as / and I chose to use sda2 as /home. I chose the same username and the same password as before. The install went fine. After the first boot, I tried to log in, but it failed. I can go to a virtual terminal and log in using my usual credentials. I can cd to /home/user/Downloads for example and all my files in the subfolders of the home directory seem to be there. Yet, when I do ls while in ~ I get the following error:

ls: relocation error: /lib/x86_64-linux-gnu/libpthread.so.0: symbol __libc_vfork, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

When I try to do nano ~/.bashrc I simply get a segmentation error. But the bash seems to have loaded my bashrc, since it looks like my usual bash. touch test gives me the same, while doing touch test in ~/Downloads works fine.

When I boot from my installation device, I can mount the partition sda2 and read fine from it. Writing is only possible by using sudo.

Any ideas what this is all about? Also: I have never used encryption of my home directory.

[EDIT]: The dmesg tells me (after trying to log in into the graphic interface)

traps: gnome-session[3282] general protection ip:[hex numbers] sp:[more hex] error:0 in libc.so.6[even more hex]

[EDIT]: I cannot do ls while in ~, but I can do ls ~ while in / and even in /home. I'm so confused right now.


Probably something went wrong with files ownership settings (can be checked ls -al /home/USER). You can repair it by:

sudo chown USER /home/USER/ -Rv
  • I just did this (removing the v option speeds this process up a lot), but I didn't fix anything. My user had the same UID (1000) in the old and in the new installation. – Wauzl Aug 10 '16 at 12:55

I feel so dumb right now. This answer is likely to be unhelpful to anyone, but it solved my problem. I had (I don't really know why) a file called libc.so.6 lying around in my home directory. I removed it via rm ~/libc.so.6 while not being in ~ and it fixed everything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.