1

Unable to install any new package or software using apt-get install on Ubuntu 14.04, error details

installArchives() failed: perl: warning: Setting locale failed. 
perl: warning: Please check that your locale settings: 
    LANGUAGE = (unset), 
    LC_ALL = (unset), 
    LANG = "en_IN.ISO8859-1" 
    are supported and installed on your system. 
perl: warning: Falling back to the standard locale ("C"). 
locale: Cannot set LC_CTYPE to default locale: No such file or directory 
locale: Cannot set LC_MESSAGES to default locale: No such file or directory 
locale: Cannot set LC_ALL to default locale: No such file or directory 
perl: warning: Setting locale failed. 
perl: warning: Please check that your locale settings: 
    LANGUAGE = (unset), 
    LC_ALL = (unset), 
    LANG = "en_IN.ISO8859-1" 
    are supported and installed on your system. 
perl: warning: Falling back to the standard locale ("C"). 
locale: Cannot set LC_CTYPE to default locale: No such file or directory 
locale: Cannot set LC_MESSAGES to default locale: No such file or directory 
locale: Cannot set LC_ALL to default locale: No such file or directory 
perl: warning: Setting locale failed. 
perl: warning: Please check that your locale settings: 
    LANGUAGE = (unset), 
    LC_ALL = (unset), 
    LANG = "en_IN.ISO8859-1" 
    are supported and installed on your system. 
perl: warning: Falling back to the standard locale ("C"). 
locale: Cannot set LC_CTYPE to default locale: No such file or directory 
locale: Cannot set LC_MESSAGES to default locale: No such file or directory 
locale: Cannot set LC_ALL to default locale: No such file or directory 
(Reading database ... 
(Reading database ... 5% 
(Reading database ... 10% 
(Reading database ... 15% 
(Reading database ... 20% 
(Reading database ... 25% 
(Reading database ... 30% 
(Reading database ... 35% 
(Reading database ... 40% 
(Reading database ... 45% 
(Reading database ... 50% 
(Reading database ... 55% 
(Reading database ... 60% 
(Reading database ... 65% 
(Reading database ... 70% 
(Reading database ... 75% 
(Reading database ... 80% 
(Reading database ... 85% 
(Reading database ... 90% 
(Reading database ... 95% 
(Reading database ... 100% 
(Reading database ... 337820 files and directories currently installed.) 
Preparing to unpack .../python-colorama_0.2.5-0.1ubuntu2_all.deb ... 
Unpacking python-colorama (0.2.5-0.1ubuntu2) ... 
dpkg: error processing archive /var/cache/apt/archives/python-colorama_0.2.5-0.1ubuntu2_all.deb (--unpack): 
 trying to overwrite '/usr/lib/python2.7/dist-packages/colorama/ansi.py', which is also in package python-batteryonboardservices 0.1-1 
Preparing to unpack .../python-setuptools_3.3-1ubuntu2_all.deb ... 
Unpacking python-setuptools (3.3-1ubuntu2) ... 
dpkg: error processing archive /var/cache/apt/archives/python-setuptools_3.3-1ubuntu2_all.deb (--unpack): 
 trying to overwrite '/usr/lib/python2.7/dist-packages/setuptools/dist.py', which is also in package python-batteryonboardservices 0.1-1 
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) 
Errors were encountered while processing: 
 /var/cache/apt/archives/python-colorama_0.2.5-0.1ubuntu2_all.deb 
 /var/cache/apt/archives/python-setuptools_3.3-1ubuntu2_all.deb 
Error in function: 
dpkg: dependency problems prevent configuration of python-pip: 
 python-pip depends on python-colorama; however: 
  Package python-colorama is not installed. 
 python-pip depends on python-setuptools (>= 0.6c1); however: 
  Package python-setuptools is not installed. 

dpkg: error processing package python-pip (--configure): 
 dependency problems - leaving unconfigured 
0
3

To fix locales check your language support settings - English (India) should be installed. If not, install it. Then run:

sudo locale-gen en_IN.UTF-8

If that doesn't generate the locale, you can use

sudo dpkg-reconfigure locales

and choose en_IN UTF-8 from the massive list to do the same thing

After generating the locale you want, check the output of locale. You want to see:

LANG=en_IN.UTF-8
LANGUAGE=en_IN:en
LC_CTYPE="en_IN.UTF-8"
LC_NUMERIC=en_IN.UTF-8
LC_TIME=en_IN.UTF-8
LC_COLLATE="en_IN.UTF-8"
LC_MONETARY=en_IN.UTF-8
LC_MESSAGES="en_IN.UTF-8"
LC_PAPER=en_IN.UTF-8
LC_NAME=en_IN.UTF-8
LC_ADDRESS=en_IN.UTF-8
LC_TELEPHONE=en_IN.UTF-8
LC_MEASUREMENT=en_IN.UTF-8
LC_IDENTIFICATION=en_IN.UTF-8
LC_ALL=

If you don't see en_IN.UTF-8 for everything, then do this:

sudo update-locale LANG="en_IN.UTF-8" LANGUAGE=en_IN:en

and check locale again. If the LC variables are still wrong, then do:

nano ~/.pam_environment

and edit so it looks like this:

LANGUAGE=en_IN:en
LANG=en_IN.UTF-8
LC_NUMERIC=en_IN.UTF-8
LC_TIME=en_IN.UTF-8
LC_MONETARY=en_IN.UTF-8
LC_PAPER=en_IN.UTF-8
LC_NAME=en_IN.UTF-8
LC_ADDRESS=en_IN.UTF-8
LC_TELEPHONE=en_IN.UTF-8
LC_MEASUREMENT=en_IN.UTF-8
LC_IDENTIFICATION=en_IN.UTF-8
PAPERSIZE=a4

(leave the papersize alone - I'm not sure what it should be for you!)

Save, exit, type: source ~/.pam_environment and now your locale is fixed.

2
  • Comments are not for extended discussion; the entire conversation that was taking place here has been moved to chat.
    – Thomas Ward
    Aug 12 '16 at 19:46
  • Problem solved. I removed my own Packages then run these following commands: 'sudo apt-get clean' 'sudo apt-get autoremove' 'sudo apt-get update' 'sudo dpkg --configure -a' 'sudo apt-get install -f' Thanks Zanna.
    – sourav
    Aug 17 '16 at 7:43
0

You have to fix the Locale problem. Then it will work again.

To fix this problem, check this thread: https://stackoverflow.com/questions/2499794/how-can-i-fix-a-locale-warning-from-perl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.