I am using Ubuntu 14.04 LTS. The desktop environment is Unity.

I changed my default terminal to lxterminal in this way: https://stackoverflow.com/a/16808639/5900630. Now, if I press Ctrl+T, lxterminal opens. Now I have

update-alternatives --config x-terminal-emulator There are 8 choices for the alternative x-terminal-emulator (providing /usr/bin/x-terminal-emulator).

  Selection    Path                             Priority   Status
  0            /usr/local/bin/lxterminal         70        auto mode
  1            /usr/bin/gnome-terminal.wrapper   40        manual mode
  2            /usr/bin/koi8rxterm               20        manual mode
  3            /usr/bin/lxterm                   30        manual mode
  4            /usr/bin/lxterminal               40        manual mode
  5            /usr/bin/uxterm                   20        manual mode
  6            /usr/bin/xfce4-terminal.wrapper   40        manual mode
  7            /usr/bin/xterm                    20        manual mode
* 8            /usr/local/bin/lxterminal         70        manual mode

Press enter to keep the current choice[*], or type selection number: 

However, my desktop launchers that has terminal=True still open gnome-terminal when they launch. Also, if I right click on a Nautilus window, and choose "Open in Terminal" (feature supported by nautilus-open-terminal), gnome-terminal starts.

PS: Don't bother with that /usr/bin/lxterminal and /usr/local/bin/lxterminal stuff... The latter one is a modified version of lxterminal that supports different color scheme. It doesn't affect the launcher behavior because I observed this on both option (4 and 8).

Example launcher file:

[Desktop Entry]
Exec=ssh -tt -p <port> <user>@<host> ssh -p <port> <user>@<host>

How to change the behavior of launchers and nautilus-open-terminal?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.