0

I just did a fresh install of Ubuntu 16.04 for my intel/nvidia combo because I could not get rid of waves/slight tearing when scrolling in chrome.

I was convinced that my nvidia chip is the issue here, but I am not sure anymore. I have created a thread for my issue here:

https://ubuntuforums.org/showthread.php?t=2327162&p=13500945#post13500945

And the one difference that I can see between a user that manages to get graphics working properly and my setup is that it seems my intel card is configured wrong.

Here is my output:

artur@pandaadb:~$ lspci -knn | grep -EA2 'VGA|3D'
00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake Integrated Graphics [8086:191b] (rev 06)
    DeviceName:  Onboard IGD
    Subsystem: Dell Skylake Integrated Graphics [1028:06e5]
--
01:00.0 3D controller [0302]: NVIDIA Corporation GM107GLM [Quadro M1000M] [10de:13b1] (rev a2)
    Subsystem: Dell GM107GLM [Quadro M1000M] [1028:06e5]
    Kernel driver in use: nvidia

I wonder if my issue is that the intel card is not using any kernel driver, since with other users the output usually says:

Kernel driver in use: i915

After my install, i am now using the nvidia 361 proprietary driver.

So the question I guess is, do i need to have the i915 driver installed? Is it already installed? How do i get my system to use this driver?

In my additional drivers settings, the intel card is also set to "unknown".

From googling I found that 16.04 has the latest intel drivers already, which is why there is no installer. I am not sure however how to get my system to actually use those drivers.

Currently I also have the device disabled (in additional drivers), to see if that would fix my issue.

EDIT: Might this be unfixable and have something to do with the vsync issue for laptops?

2

i have a dell precision m3800 which has a similar setup , it works fine with the drivers from https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

i have found that nvidia-358 and nvidia-367 seem to work best with my quadro K1000M , i don't get any tearing on its built it 4k screen or my external one.

Heres my xorg.conf for running with full nvidia acceleration as generated by nvidia-settings

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:2@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection

my display hardware looks like this :

amias@rome:~$ sudo lshw -class display
[sudo] password for amias: 
  *-display               
       description: 3D controller
       product: GK107GLM [Quadro K1100M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:67 memory:eb000000-ebffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:ec000000-ec07ffff
  *-display
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:56 memory:ec400000-ec7fffff memory:80000000-8fffffff ioport:f000(size=64)
  • I have tried both of those and can't get scrolling or my terminal to stop lagging. Is your intel card recognised? – pandaadb Aug 10 '16 at 8:43
  • I tried your approach and the 367 is not solving my issues. I seem to not be able to get the intel driver to work properly. Nvidia says it is syncing to "unknown". The terminal is still laggy when typing and scrolling in the browser causes tearing – pandaadb Aug 10 '16 at 10:22
  • heres my glinfo amias@rome:~/Downloads$ glinfo -v Kernel = 4.4.0-31-generic Renderer = OpenGL renderer string: Quadro K1100M/PCIe/SSE2 Nvidia Modules Loaded = 5 Intel Modules Loaded = 5 – Amias Aug 10 '16 at 10:27
  • Does it show that the VGA card has a driver in use? I am wondering if maybe the intel driver is configured wrong and that breaks the syncing? I can't get my system to use the intel driver (i think) – pandaadb Aug 10 '16 at 10:38
  • use the modesetting driver for the intel card – Amias Aug 10 '16 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.