2

I'm still new to linux/ubuntu, so please bear with me.

I'm trying to get IPv6 working. IPv4 (and my internet) works fine, but when I test for IPv6 on ipv6-test.com it says I don't have IPv6:

enter image description here

My windows machine (on same network) works mostly fine however:

enter image description here

I've tried the code:

test -f /proc/net/if_inet6 && echo "Running kernel is IPv6 ready"

Which brings up "Running kernel is IPv6 ready"

Not sure where to go from here (still learning this). Thanks for any help.

6
  • 1
    And where is your IP address coming from exactly? Are you specifying it manually?
    – dobey
    Aug 9 '16 at 1:28
  • Oh, it's coming from router dhcp.
    – TimothyC
    Aug 9 '16 at 1:30
  • 1
    Does your ISP give you an IPv6 prefix? Does your router handle IPv6? What does ip address say, are there any inet6 addresses not starting with f?
    – Dubu
    Aug 9 '16 at 21:33
  • Yeah ISP gives prfix (2600: ...), and router does support it. Far as I can tell all my devices/machines can function over IPv6. Even my pi (running Raspbian Jessie) shows as supported on that web test, and also gets (over DHCP from router) a IPv6 address with prefix. 'ip address' lists 4 addresses (excluding loopback), one IPv4 which is correct, and three IPv6. The three IPv6 addresses all start with 'fe' and say 'scope link tentative dadfailed' after, and 'valid_lft forever preferred_lft forever' below.
    – TimothyC
    Aug 9 '16 at 22:45
  • Are you sure it is coming from dhcp6 rather than autoconfigured via router advertisements? Did you configure dhcpv6 on the router? Aug 28 '16 at 18:21
0

It seems you have to set up DHCP to issue v6 requests on dhclient.conf.

Check this out: https://wiki.ubuntu.com/DHCPv6 (ISC DHCP v6 Client section).

There it suggests you can enable it by adding this line to /etc/dhcp/dhclient.conf:

send dhcp6.oro 1, 2, 7, 12, 13, 23, 24, 39;

If you want to dig further on DHCP client settings refer to its man page, accessible either via the man dhclient.conf and this link: http://linux.die.net/man/5/dhclient.conf

4
  • I added 'send dhcp6.oro 1, 2, 7, 12, 13, 23, 24, 39;' to the dhclient.conf, and restarted networking/dhclient but nothing seemed to have changed. I looked at linux.die.net/man/5/dhclient.conf and noticed it didn't have the 'From man dhclient.conf:' block of text mentioned on wiki.ubuntu.com/DHCPv6 which seems strange.
    – TimothyC
    Aug 9 '16 at 6:39
  • True! It seems options on ubuntu's dhcp client with v6 support are not exactly the same in the original package. But that's amusing, they have a page to fix this specific issue with specific instructions... that don't work.
    – Avenger
    Aug 9 '16 at 21:55
  • Do you have a line that reads iface eth0 inet dhcp in your /etc/network/interfaces file? if so, try adding also a iface eth0 inet6 dhcp line, that will be at least one of the causes it don't work.
    – Avenger
    Aug 9 '16 at 21:57
  • I added that line, didn't seem to affect anything however. The file contained a comment and 2 lines, 'auto lo' & 'iface lo inet loopback'. The line is in there now though.
    – TimothyC
    Aug 9 '16 at 23:03
0

I've found the "wide-dhcpv6-client" to be a little friendlier than that of ISC. Once installed, make sure you update /etc/default/wide-dhcpv6-client to match your intended interface. Take a look at /etc/default/wide-dhcpv6-client as well. Here's a decent starting point for a config:

interface eth0
{ 
  send ia-na 1;
  send ia-pd 0;
  request domain-name-servers;
  request domain-name;
  request ntp-servers;
  script "/etc/wide-dhcpv6/dhcp6c-script";
};

Also, on 16.04, be careful with some of the sysctl options. There are some odd defaults that were introduced. You can show your route table with "ip -6 route". It should have a default listed (regardless of DHCP) if your router is indeed sending out RAs to the network. If not, check to make sure it's enabled with:

sysctl -a | grep accept_ra_defrtr

Your interface should not show "0" for that option if you're expecting a default route to be learned via RAs.

Dan

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.