1

I've got a problem with Ubuntu 16.04 (fresh install beside Windows 10 installation) boot taking a very long time on my Samsung 850 EVO SSD - almost 1 minute.

The story goes like this:

  1. GRUB menu shows up
  2. after I hit enter, for about 40 seconds I can only see a default purple GRUB's background (without a menu)
    • looking at the IO/disk diode I can clearly see that my disk is under heavy load during that period
  3. after that, the screen is turned off and on (like at the beginning of a typical reboot) and Ubuntu login screen shows up

I've checked dmesg/system log - here's the important fragment:

(...)
Aug  8 19:27:15 MS-7586 systemd[1]: Starting Unattended Upgrades Shutdown...
Aug  8 19:27:15 MS-7586 systemd[1]: Stopping Daemon for power management...
Aug  8 19:27:15 MS-7586 systemd[1]: Stopping Disk Manager...
Aug  8 19:27:15 MS-7586 systemd[1]: Stopping Session c2 of user sokol.
Aug  8 19:27:15 MS-7586 rsyslogd: [origin software="rsyslogd" swVersion="8.16.0" x-pid="2378" x-info="http://www.rsyslog.com"] exiting on signal 15.
Aug  8 19:31:05 MS-7586 rsyslogd: [origin software="rsyslogd" swVersion="8.16.0" x-pid="2357" x-info="http://www.rsyslog.com"] start
Aug  8 19:31:05 MS-7586 rsyslogd-2222: command 'KLogPermitNonKernelFacility' is currently not permitted - did you already set it via a RainerScript command (v6+ config)? [v8.16.0 try http://www.rsyslog.com/e/2222 ]
Aug  8 19:31:05 MS-7586 rsyslogd: rsyslogd's groupid changed to 108
Aug  8 19:31:05 MS-7586 rsyslogd: rsyslogd's userid changed to 104
Aug  8 19:31:05 MS-7586 systemd-modules-load[875]: Inserted module 'lp'
Aug  8 19:31:05 MS-7586 systemd-modules-load[875]: Inserted module 'ppdev'
Aug  8 19:31:05 MS-7586 systemd-modules-load[875]: Inserted module 'parport_pc'
(...)

(I've added debug kernel parameter to 'Ubuntu' GRUB entry during that reboot)

The interesting thing is that 19:30:22 (7:30:22 PM) was the time when I've selected 'Ubuntu' in the GRUB menu. I've seen Ubuntu login screen at 19:31:08. In other words, that ~40 seconds "freeze" during the boot time is not recorded in the system log. systemd-analyze output confirms that Ubuntu startup itself is pretty fast and does not take part in that ~40 seconds period:

Startup finished in 4.704s (kernel) + 1.709s (userspace) = 6.414s

When it comes to GRUB, I've tried:

GRUB_CMDLINE_LINUX_DEFAULT="reboot=pci"

as well as the default value. No difference.

Also, UUIDs from the blkid match those listed in /etc/fstab file.

Apart from these boot issues, I cannot see any problems with the SSD in general (currently it's the only disk I'm using). I hadn't got any problem with unusually long boot time while using my previous HDD, before I've upgraded to SSD.

Haven't done anything with my BIOS (updates etc.) since then.

Many thanks for any suggestions!

UPDATE #1:

I've removed splash from GRUB_CMDLINE_LINUX_DEFAULT as suggested by @ByteCommander, but - as expected - it doesn't change much. Now I just don't need to hit Esc to see the log while the system is booting.

Nothing interesting at /var/log/Xorg.0.log either. X Window starts - as expected - after the initial boot stuff, while the freeze occurs way before that...

...With GRUB_CMDLINE_LINUX_DEFAULT set to reboot=pci (without splash and quiet), before first systemd output line appears on a screen during the boot, there is ~38 second freeze (purple background + high disk load).

  • You could try and remove the splash from your GRUB_CMDLINE_LINUX_DEFAULT as well. Not sure if that will result in more output... – Byte Commander Aug 8 '16 at 20:17
  • Did you look in other log files like /var/log/Xorg.0.log? – ubfan1 Aug 8 '16 at 22:14
  • @ByteCommander: It's not necessary, as the splash without quiet just requires to hit Esc (which I've done) to see the log output. Anyhow, nothing interesting there, unfortunately. @ubfan1: Yes, I've checked all that I'm aware of, including /var/log/Xorg.0.log. As expected, nothing special there. – falconepl Aug 11 '16 at 21:06
0

Problem solved. I had a chance to put that SSD into the Lenovo L540 laptop - the system boots in a few seconds and both read & write speed test shows 500+ MB/s data transfer rate. Thus, it's definitely not a software but hardware issue - either my PC motherboard MSI P55-CD53 is broken or the SATA cable causes some problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.