1

Today I interrupted my Kubuntu update and now it doesn't run. I get the below error message. I need the data on this.

My system is a dual boot with Windows 7

error message


I tried Karsus' answer but I still have issues.

I managed to boot from a live USB with Kubuntu(14.04). I enter the console and gave following commands.

    sudo -s
    mkdir /data1
    fdisk -l (my partition is called sda6)
    mount /dev/sda6 /data1
    chroot/data1

and then I followed your commands, beginning with

    sudo dpkg --configure -a
    sudo dpkg-reconfigure -phigh -a

    sudo apt-get update
    sudo apt-get install -f
    sudo apt-get autoclean
    sudo apt-get autoremove

The system worked, but it doest solved my problem. It is still the same error message.

It doesnt disturbe me, if i have to set up everything, but at least i want to save all data from the partition

P.S. I can start from an older version of my kernel, but it gives me the same error message

1 Answer 1

3

I would do the following:

  1. When starting your PC, go into the grub menu. If that doesn't happen automatically because of dual boot, you can do it by holding SHIFT. Once you are in the grub GUI menu, select an older kernel than the one you were using to boot.

If 1 doesn't work:

  1. Boot your system with a live USB.

  2. Back up up all your data. You can move them to another partition, or - better - to an external hard drive.

After backing up all your data you have two options:

  1. Reinstall the OS.

  2. Try to repair your package installation.


Edit: Adding Hi-Angel's suggestion.

You can also try to repair your installation from a live USB. After booting, you will need to mount the drive where Kubuntu is located. The below is written assuming it's mounted at /dev/media. If not, change the below lines appropriately.

sudo -s
mkdir /media/Ubuntu
mount /dev/media /media/Ubuntu 
cd /media/Ubuntu
mount -t proc /proc proc 
mount --rbind /sys sys
mount --rbind /dev dev
mount --rbind /run run
chroot /media/Ubuntu /bin/bash

After that, proceed as if you had booted from old kernel.


You can try to repair (assuming you managed to boot from an older kernel) with:

sudo -s # If you haven't already from live usb
dpkg --configure -a
dpkg-reconfigure -phigh -a

See here to read what these commands do.

For good measure you can also run these:

apt-get update
apt-get install -f
apt-get autoclean
apt-get autoremove

If everything worked, reboot and load the latest kernel.

If something goes wrong and assuming you want to rescue your system instead of re-installing you can then remove the offending kernel following suggestions from this answer. Reboot after removing and then run the update process normally to re-install it.

6
  • ⁺¹ though, but you omitted an important step, before running dpkg commands they have to mount to LiveCD procfs, tmpfs, etc. Here's, in the end of paragraph, an example of mount commands. I actually think, reinstalling kernel would be enough.
    – Hi-Angel
    Aug 8, 2016 at 17:03
  • Aw, you probably meant to run them from rescue prompt, sorry, I thought it goes about LiveUSB.
    – Hi-Angel
    Aug 8, 2016 at 17:09
  • 1
    Right; I think it would be: 1. Mount the Ubuntu, e.g., to /media/Ubuntu, then (with elevated priveledges): mount --bind /media/Ubuntu /media/Ubuntu && cd /media/Ubuntu && mount -t proc /proc proc && mount --rbind /sys sys && mount --rbind /dev dev && mount --rbind /run run && chroot /media/Ubuntu /bin/bash.
    – Hi-Angel
    Aug 8, 2016 at 17:19
  • 1
    @Hi-Angel Thanks for clearing that up. I added your suggestion. I broke the commands so if he gets an error it's easier for him to see after which command it happened and tell us.
    – Karsus
    Aug 8, 2016 at 17:35
  • 1
    You don't need --bind to mount a drive. And btw, I'd recommend to remove all sudo from the post, and just to note that before commands one ought to run sudo -s to get elevated privileges. That would allow simple copy-paste, because ATM one need to write a password after the first sudo, which isn't obvious for a newbie.
    – Hi-Angel
    Aug 9, 2016 at 5:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.