1

Trying to upgrade to 16.04. Currently on the "Installing the upgrades" section. The Distribution Upgrade window has been "Configuring procps (amd64)" for about 3 hours now. I'm thinking it might be stuck? Any way to determine if that is the case? And if it is, the best way to interrupt the upgrade and restart?

  • 1
    I think it's normal, for me it took about 4 hours. – Hi I'm Frogatto Aug 8 '16 at 16:18
  • It took 4 hours for the entire upgrade or 4 hours for configuring procps? – mrw0614 Aug 8 '16 at 16:52
  • Found a log file: /var/log/dist-upgrade/main.log and at the end: 2016-08-08 08:46:18,966 WARNING no activity on terminal for 300 seconds (Configuring procps (amd64)) 2016-08-08 10:34:35,894 WARNING no activity on terminal for 300 seconds (Configuring procps (amd64)) 2016-08-08 11:02:00,000 WARNING no activity on terminal for 300 seconds (Configuring procps (amd64)) Sure looks stuck to me! Any way to kill gracefully? – mrw0614 Aug 8 '16 at 17:01
  • Configuring is the slowest process in the upgrade, so it's normal to take you about 3 to 4 hours. – Hi I'm Frogatto Aug 8 '16 at 17:04
  • In a similar post when someone was upgrading to 11.10 it wound up taking 7 hours. I'm going to let this run overnight and I'll check back in tomorrow. If it does manage to finish I'll try to determine how long it took and post it for those interested. If it doesn't, I'm still interested in advice on the best way to kill it, attempt clean up if possible, and restart it. – mrw0614 Aug 8 '16 at 19:26
1

Okay, so the install was stuck - still not exactly sure why. I wound up killing it. To recover, I did the following (found in another post): 1) sudo dpkg --configure -a 2) sudo apt-get update 3) sudo apt-get upgrade There were packages that were held back, but when I tried to install them with: 4) sudo apt-get install package-name another-package-name they all failed to install. I'm not sure yet whether those will be an issue or not in the long run... Then I did: 5) sudo apt-get autoremove to clean things up. Then crossed my fingers (an important step) and rebooted. And lo and behold it came up. Things seem to look like they did before so that's a relief. Thanks Frogatto for replying to me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.