0

Trying to run sudo apt-get install -f fails because I'm out of disk space:

udev                           3.9G  4.0K  3.9G   1% /dev
tmpfs                          789M  812K  788M   1% /run
/dev/mapper/colorado--vg-root  139G   28G  105G  21% /
none                           4.0K     0  4.0K   0% /sys/fs/cgroup
none                           5.0M     0  5.0M   0% /run/lock
none                           3.9G  4.0K  3.9G   1% /run/shm
none                           100M     0  100M   0% /run/user
/dev/sda2                      237M  230M     0 100% /boot
/dev/sda1                      487M  3.4M  483M   1% /boot/efi
/dev/sdc1                      3.7T  2.3T  1.4T  63% /media/plex

I'm guessing this must be because of Docker, but now I'm not using it and I'd like to free up that space — looking at you, /dev/mapper. I tried using - s devicemapper --storage-opt dm.fs=xfs --storage-opt dm.mountopt=discard (https://github.com/docker/docker/issues/18867) but that fails:

INFO[0000] API listen on /var/run/docker.sock           
WARN[0000] Usage of loopback devices is strongly discouraged for production use. Please use `--storage-opt dm.thinpooldev` or use `man docker` to refer to dm.thinpooldev section. 
FATA[0000] Error starting daemon: error initializing graphdriver: exec: "mkfs.xfs": executable file not found in $PATH 

Not sure where to go from here. Am I screwed?

Running Ubuntu Server 14.04.

5
  • The only partition that appears to be full is /dev/sda2 which is mounted at /boot. What is the exact error message you receive from apt-get? – Nathan Osman Aug 8 '16 at 3:43
  • Does sudo apt-get autoremove work? I'm guessing you have some old kernels in there that could be removed. – Nathan Osman Aug 8 '16 at 3:43
  • autoremove wants the linux-image dependencies and recommends -f... which fails, because i'm out of disk space. – AFL Aug 8 '16 at 3:45
  • Ah. If you can get the exact package names that apt-get autoremove would remove, then you may be able to forcibly remove them with dpkg. – Nathan Osman Aug 8 '16 at 3:46
  • 1
    Cross posted (and put on hold) at U&L – Anthon Aug 8 '16 at 5:52
1

This has unlikely anything to do with docker. Docker normally stores its container info on /var/lib/docker and that is on your / mount point which has 105Gb free.

What is full is /boot, probably because of multiple old images. If you cannot uninstall these the normal way first look at what image you are running:

uname -r then at what is under /boot:

ls -l /boot and remove a initrd.img.... and/or vmlinux... file that doesn't match the kernel version that you are actually running.

After you freed up some space you should be able to use apt-get again.

1
  • This fixed it! /dev/sda2 237M 78M 147M 35% /boot – AFL Aug 8 '16 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.