1

I recently set my computer up to dual boot Ubuntu 14.04 and Windows 10, but I discovered last night that I cannot access the internet (wired or wireless) on the Ubuntu side. The internet works fine on the Windows side, but not on Ubuntu. I've done a lot of searching and all of the stuff I've found hasn't helped any.

I am able to ping my router's IP, but when I try to ping 8.8.8.8 I just get a "Destination Host Unreachable" . Trying to ping www.google.com returns "unknown host wwww.google.com".

I'm not sure what to do at this point. I do programming, and I much prefer programming in a Unix environment but don't want to have to use a virtual machine. Thanks for any help.

Edit:

Output of ifconfig:

eth0      Link encap:Ethernet  HWaddr 74:d4:35:5e:f0:d8  
          inet6 addr: fe80::76d4:35ff:fe5e:f0d8/64 Scope:Link
          inet6 addr: 2607:fcc8:ae03:ab00:76d4:35ff:fe5e:f0d8/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:47 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2208 (2.2 KB)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:608 (608.0 B)  TX bytes:608 (608.0 B)

Output of iwconfig:

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

eth0      no wireless extensions.
  • Can you give the output of ifconfig? – fakedad Aug 8 '16 at 2:22
0

When I had a similar issue, it was because I hadn't set the DSN Address correctly. If you're using static IP addresses, it would be worth checking. (In my case, I had a minor typo)

sudo nano /etc/network/interfaces

ensure you set a valid dsn address - I use google's

auto eth0
iface eth0 inet static
address 192.168.0.210
gateway 192.168.0.1
netmask 255.255.255.0
dsn-nameservers 8.8.8.8 8.8.4.4
  • I did this, but it didn't work. It actually just completely removed the wired connection option from the network thing on the menu bar. Now it says "device not managed" under Ethernet Network. – kcatt Aug 9 '16 at 1:31
0

I just figured out my issue from solving a different issue that I didn't think would be related from here: https://unix.stackexchange.com/a/72698. My motherboard is a newer Gigabyte and enabling the IOMMU option in the BIOS fixed both my networking issue and an issue I was having where the USB ports would quit working occasionally on reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.