35

I was using byobu on Ubuntu 11.10 Server and I needed to hit a function key in an app, so I hit F9 to bring up the config menu and switched the keybinding set from "f-keys" to "screen-escape-keys". That worked, but now I can't re-enable all the f-keys.

I found a program byobu-config that brings up the menu again, and I can switch back to screen keys from there. This fixes things for new screen processes, but the effect on the current screen session is weird: it disables the Ctrl+a (screen) keys and restores F2-F8, but F9-F12 still don't do anything (they're just passed on to the foreground process).

What's up with this? Any ideas? Thanks in advance.

5 Answers 5

54

Note: This only works if you're using Byobu with tmux as the back-end. See other answers for Byobu with screen as the back-end.


Just press Shift+F12 To toggle F-keys on and off.

Example : Launch htop (within a Byobu pane of course) then enter Shift+F12, then if you press F3 you will search in htop processes, not switch to the left Byobu window/pane.

Related question with answer also for screen.

7
  • 9
    Note to future self: ignore the accepted answer status - this doesn't work for me.
    – Yang
    Oct 14, 2012 at 20:15
  • 1
    Thank you very much. I was struggling to figure out why I can't switch windows all of a sudden.
    – wujj123456
    Nov 5, 2012 at 19:44
  • 4
    Does not work any more... (using ubuntu 12.04.1)
    – zipizap
    Jan 9, 2013 at 15:01
  • 2
    Works on Ubuntu 14.04 Jul 29, 2015 at 20:00
  • 1
    I guess this does not work on byobu-screen. Check @Dustin Kirkland's answer if does not work for you and you use byobu-screen. Feb 10, 2016 at 17:08
14

You can also toggle between the f-keys bindings and the screen-escape-keys bindings using:

ctrl-a-!
4
  • 2
    Here this displays the message "can't break with only one pane" are you sure of this shortcut ?
    – yPhil
    Oct 1, 2012 at 8:42
  • 4
    That only works in byobu-screen, not in byobu-tmux (bugs.launchpad.net/byobu/+bug/386363). In the latter the correct combination is SHIFT-F12.
    – invernizzi
    Nov 28, 2012 at 20:40
  • This does work on Ubuntu 12.04.1 (NOTE: answer SHIFT-F12 does not work)
    – zipizap
    Jan 9, 2013 at 15:03
  • 1
    Note that this will also reset your meta/escape key, probably because it just sources /usr/share/byobu/keybindings/f-keys.screen.disable which has the line escape ^Aa. If you for example used 't' as your escape key you can set it again by hitting ctrl-a and then :escape ^Tt.
    – Perseids
    Feb 15, 2014 at 10:29
4

We can attempt to debug your particular problem, however it would be much easier to just clean out your Byobu configuration and start clean:

rm -rf ~/.byobu

On 11.04, you'll also need to remove the folder this symlink points to:

rm -rf ~/.local/share/byobu

And then start byobu.

2

In case any of the key combinations from the other answers did not work, just try this equivalent command inside Byobu:

byobu-keybindings
1

Make your ~/.byobu/keybindings look like this:

# source $BYOBU_PREFIX/share/byobu/keybindings/common
. /usr/share/byobu/keybindings/f-keys.screen.disable

and select screen as byobu's back-end via byobu-select-backend. That works in Debian, at least.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.