0

I installed Ubuntu 14.04 on a Lenovo Yoga 300 which comes with a built in battery. Everything works, but the system does not detect the battery. When entering acpi -V in terminal it displays:

Adapter 0: on-line
Cooling 0: soc_dts1 no state information available
Cooling 1: soc_dts0 no state information available
Cooling 2: B0DB no state information available
Cooling 3: INT3400 Thermal no state information available
Cooling 4: intel_powerclamp no state information available
Cooling 5: Processor 0 of 10
Cooling 6: Processor 0 of 10
Cooling 7: Processor 0 of 10
Cooling 8: Processor 0 of 10

It does detect when I unplug the adapter.

Thanks for any help.

1

I have the same problem in Xubuntu 16.10 (I also tried Xubuntu 16.04 and confirm it is a problem there as well). There are suspicious messages from dmesg:

[    2.575759] ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000010) is beyond end of object (length 0xD) (20160422/exoparg2-427)
[    2.575775] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.H_EC.BAT1._BIX] (Node f6091408), AE_AML_PACKAGE_LIMIT (20160422/psparse-542)
[    2.575794] ACPI Exception: AE_AML_PACKAGE_LIMIT, Evaluating _BIX (20160422/battery-450)

I have googled this extensively and I think a fix to the acpi driver might be necessary, e.g.:

http://www.spinics.net/lists/linux-acpi/msg69261.html

UPDATE I have confirmed that if you apply a patch similar to the one in the link above and build a custom kernel, the battery information is available! In my case I modified the patch a little bit to make sure the "_BIF" method is used and not the "_BIX" one. Hopefully this patch can eventually become part of an official kernel.

| improve this answer | |
1

The patch (patchwork.kernel.org/patch/9337413) is included in newer kernels. The problem is solved ;-) (more Info: Problem -was- a buggy firmware -BIX-method fails)

Battery detected again with kernel 4.10.rc5

Tested on: Lenovo Ideapad 300s-11IBR (with Manjaro Linux, Kernel: 4.10.0-1-MANJARO)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.