30

How to fix The destination is read-only error on HDD partition with Windows 8.1 dual boot?

enter image description here
Error while copying to ntfs partition

enter image description here

10
  • 1
    Mount it read-write.
    – dadexix86
    Aug 7, 2016 at 13:53
  • how can i do this
    – VJ Ranga
    Aug 7, 2016 at 13:56
  • Start by posting a screenshot of Gparted.
    – dadexix86
    Aug 7, 2016 at 13:57
  • what i can't understand this please explain
    – VJ Ranga
    Aug 7, 2016 at 14:04
  • 1
    please tell me what do now
    – VJ Ranga
    Aug 7, 2016 at 14:41

4 Answers 4

68

For me the solution was quite simple:

killall nautilus

First I tried with gpart and disk utilities to erase the partition but the problem still there, I saw answers about mount by hand or about win solutions but it doesn't make sense for me because my usb was created with an image of ubuntu with dd!. At the end, it seems to be a nautilus's bug. Just restart your PC or kill your nautilus and the problem will gone.

6
  • Does logging out and back in also work? Oct 27, 2017 at 15:21
  • I certainly don't know but I suppose. But it's easier to open a terminal with ctr-alt-t and you don't lose your opened windows.
    – Rodrigo
    Jan 22, 2018 at 18:45
  • 1
    Same works also for Thunar: killall Thunar
    – Bart Weber
    Jan 28, 2018 at 10:40
  • 2
    This worked for me for a mounted network volume. That's just bizarre. Thank you.
    – mikato
    Feb 2, 2018 at 22:31
  • 1
    Also worked with Nemo for me on Mint 18.3.
    – anderstood
    Jun 14, 2018 at 16:21
9

I have the same issue and tried almost everything. Fortunately, found a solution to the problem from this thread : Read-only partition, dual boot WIn10

The Windows 10 update reseted it to the default fast startup which is a form of hibernation.

You need to disable this feature (again, probably) in Windows and then shutdown, not reboot. Once done properly you'll be able to access the data partition normally with read/write permissions.

How to disable hibernate on windows : https://www.cnet.com/how-to/how-to-enable-or-disable-hibernate-in-windows-10/

6

Open the terminal (MAKE SURE THAT YOU DON'T HAVE ANYTHING OPEN THAT USES THAT DRIVE!) and then type:

sudo mount -o remount,rw  /dev/sda3

Now you should have the drive mounted as read-write. If not, then try:

sudo mount -f -o remount,rw /dev/sda3

or sudo umount /dev/sda3 sudo mount -rw /dev/sda3

If the umount was successful but the mount after it was failed try to put at the last mount command in this answer, in front or after the -rw argument -f to force the operation.

(NOTE: I HAVEN'T TRIED THIS BUT I'VE USED THESE COMMANDS AT MY OWN PROBLEMS LIKE THIS BUT ONLY SOME OF THEM ARE WORKING. FOR ME THIS WAS HAPPEN A WHILE AGO AND I CAN'T REMEMBER THE EXACT SAME COMMANDS THAT I USED TO FIX THE PROBLEM AND THERE CAN BE SOME SYNTAX ERRORS AT SOME COMMANDS AND I CAN MISSED SOME COMMANDS THAT CAN FIX YOUR PROBLEM.)

4
  • i'll try this but i can't do this
    – VJ Ranga
    Aug 7, 2016 at 15:11
  • i think i can't understand that
    – VJ Ranga
    Aug 7, 2016 at 15:12
  • Shortly: Open terminal and type : sudo mount -o remount,rw /dev/sda3 /mnt/8C7496A274968E98 then press enter. Aug 7, 2016 at 18:25
  • i tryed but it not work
    – VJ Ranga
    Aug 9, 2016 at 3:41
6
sudo mount -o remount,rw /dev/sdd1

replace sdd1 with your hdd or pendrive.

To check which one is yours type in terminal:

lsblk

and find your drive there and notice the device or partition and replace yours in above command.

this might work :)

note: "replace partition not disk"

1
  • 6
    The right command is lsblk not lsblck.
    – Fred Rocha
    Apr 17, 2017 at 13:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.