1

System: Ubuntu 14.04, Intel i7, 16GB RAM, GTX 980 video card (usually I run the 352 driver from Nvidia)

So, admittedly I am not very good at Linux. I updated to 3.19.0-65, which (as noted elsewhere) now requires Secure Boot. Nvidia drivers don't work with that, so I wasn't able to log in to the GUI on reboot. I was able to get the system to boot from the GRUB menu to the older 3.19.0-64 kernel in recovery mode, so I tried to purge the 3.19.0-65 kernel in hopes that 3.19.0-64 would become the new default. When I rebooted it was still expecting 3.19.0-65 and the boot failed.

So... cut to several hours later, and I've managed to use boot-repair-disk to fix GRUB and I can boot to the login screen again. I've purged all of the kernels, and installed only two: 3.19.0-64-generic and 3.19.0-64-lowlatency. I've also turned off Secure Boot in both GRUB (deselecting that option in boot-repair-disk) and in my BIOS.

I still can't get into the GUI - it shows the login screen at low resolution but when I put my password in it just kicks me right back to the same screen. Using ubuntu-drivers I can see my video card is "UNCLAIMED" and that doesn't change when I install the driver from a terminal and/or reboot. And that's only in the "lowlatency" kernel - in the "generic" kernel, it takes me to the screen where I enter the passphrase to decrypt my harddrive, and the keyboard doesn't work (no characters appear no matter what I type).

I'm really at a loss here, please let me know what additional information I can provide.

  • Disable Secure boot in BIOS. – Pilot6 Aug 7 '16 at 8:12
  • I have, it won't boot at all without that. – GodLovesUGaius Aug 7 '16 at 12:38
0

Found this..

"... my kernel was skipped so I manually upgraded/installed linux-image-3.16.0-24-generic. It turns out most of the drivers you need live in linux-image-extra-3.16.0-24-generic and you'll need the headers too."

Use your working kernel & run the command below *(I believe you'll need to change the kernel version #'s to yours):

sudo apt-get install linux-image-extra-3.16.0-24-generic linux-headers-3.16.0-24-generic

source: askubuntu - "No user input after upgrading to ubuntu 14.10 with linux kernel 3.16"

I think you ought to temporarily install nouveau/xserver until you find a way to successfully achieve what you initially had planned, or...

(14.04+) ..If you want to try the newest method for installing Nvidia drivers using 'graphics-drivers' PPA, then see below. It may be a bit risky.


Installing the recommended Nvidia driver from PPA

  1. Add the 'graphics-drivers' PPA with these commands:
    • sudo add-apt-repository ppa:graphics-drivers/ppa
    • sudo apt-get update
  2. Autoinstall the recommended driver with:
    • sudo ubuntu-drivers autoinstall
  3. Now reboot with:
    • sudo reboot

If the recommended driver does not work for you, try installing a different Nvidia driver.

(See below)


Installing other Nvidia drivers from PPA

  1. Add the 'graphics-drivers' PPA with:
    • sudo add-apt-repository ppa:graphics-drivers/ppa
    • sudo apt-get update
  2. Purge existing Nvidia packages you have installed (if any):
    • sudo apt-get purge Nvidia*
  3. Check available drivers for your system with this command:
    • ubuntu-drivers devices
  4. Install the recommended driver:
    • sudo apt-get install nvidia-361
  5. Lastly, reboot with:
    • sudo reboot

source: askubuntu - "Ubuntu 14.04 install nVidia driver"

  • I don't have a "working kernel" but I am able to use a live USB to mount the filesystem and chroot into it as in these instructions: askubuntu.com/questions/28099/… – GodLovesUGaius Aug 7 '16 at 12:48
  • I used apt-get to install linux-image-3.19.0-64-generic, that's the kernel that won't let me type anything. I tried installing linux-image-3.19.0-24-generic but it says it can't find that package. – GodLovesUGaius Aug 7 '16 at 12:51
  • And that is the method I used to install the drivers. But the card still shows up as UNCLAIMED – GodLovesUGaius Aug 7 '16 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.