2

Every time I boot into Ubuntu 16.04 (I dual-boot with Windows 10), I've run sudo apt-get update followed by sudo apt-get upgrade to keep the Ubuntu side of things up-to-date.

Several times in the past month, the second command hangs with the following output (only the last few lines included):

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.4.0-31-generic
Found initrd image: /boot/initrd.img-4.4.0-31-generic
Found linux image: /boot/vmlinuz-4.4.0-28-generic
Found initrd image: /boot/initrd.img-4.4.0-28-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin

Pressing Ctrl+C doesn't seem to have any effect.

Looking around online, it seems this is related to update-grub. I decided to use top to see if anything interesting was happening, or if it was just stuck waiting for something that never seems to come. The only remarkable process was mount.ntfs, which was using 99-100% CPU.

This question is very similar to this one: 14.04 Dpkg Found kernel: /memtest86+.bin issue (freeze during update-grub), and might even be a duplicate. In that question, the user was able to restart and audit/configure things via dpkg. (Is there a way to do this without restarting?) I've tried a similar thing, but my problem persists. I should not have to do that every couple days.

I've tried Ctrl+Z apt-get, but suspending the process doesn't really help. Interestingly, while suspended, mount.ntfs still goes at about 100% CPU. I closed the file backup program in case that may have been what was invoking mount.ntfs, but it still uses about 100% CPU.

Hopefully I've provided enough detail here to make this question specific and sufficiently unique:

What might be going on here, and how might it be fixed?

4
  • I'm a little nervous to reboot if there's something wrong with Grub....
    – jvriesem
    Aug 6, 2016 at 23:00
  • Can you get to recovery mode from GRUB? Can you still boot to Windows 10 from GRUB? The answers to these questions will determine what I suggest next.
    – heynnema
    Aug 6, 2016 at 23:44
  • I can still boot to everything. I'm just nervous, because I did something once to fix this problem (I forget what), and I wasn't able to boot into Windows. #PanicAttack
    – jvriesem
    Aug 8, 2016 at 18:20
  • OK then, just to be safe, try this. Open a "FILES" manager (nautilus) window from the Dash, and in the left pane, click on the name of your Windows partition, and it SHOULD mount to the desktop... but I bet it won't. Report back. (Do you know how to run chkdsk in Windows?) (Do you know how to turn off FAST BOOT in Windows?)
    – heynnema
    Aug 8, 2016 at 23:33

2 Answers 2

3

To fix the issue of the problem - os-prober - you can:

# vi /etc/default/grub
GRUB_DISABLE_OS_PROBER=true
0

Try to:

  1. kill os-prober process
  2. run sudo umount /var/lib/os-prober/mount
  3. run sudo update-grub again
3
  • Given that four years have passed since the question was asked, could you be a bit more specific about why this process might solve the problem? It could help others in the future 🙂
    – user1091774
    Dec 14, 2020 at 14:42
  • @Matogo, no. Idk. But, I think, the problem is /var/lib/os-prober/mount is mounted and it cause a problem
    – ExposedCat
    Dec 14, 2020 at 16:32
  • The umount command itself hangs for me Sep 9, 2021 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.