It's been 3 weeks since I updated Ubuntu from 14.04 to 16.04, and I still can't use my graphic card normally. I remembered too late that I installed manually my drivers during the setup of my previous version. My upgrading wiped that custom install.

I can't use a second screen (it's not detected), and I can't play. I'm rewriting my question today to document all this and save time for somebody else. As far as I know, it may be just impossible for now to make my graphic card work with Ubuntu 16.

Context

I have a Lenovo Thinkpad T440P, lspci | grep VGA returns this:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
02:00.0 VGA compatible controller: NVIDIA Corporation GK208M [GeForce GT 730M] (rev a1)

sudo lshw -c video returns this:

  *-display UNCLAIMED     
       description: VGA compatible controller
       product: GK208M [GeForce GT 730M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f0000000-f0ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:3000(size=128) memory:f1000000-f107ffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f1400000-f17fffff memory:e0000000-efffffff ioport:4000(size=64)

I have two graphic cards, but installing nvidia-prime don't do anything to the problem.

The problem

When I install Nvidia plugin (from the Nvidia website), I can't connect to my computer.

At first I was using lightdm, and I was stuck in this login loop. Then I switched to my usual gdm, and now I can't even try to login, I get a weird unstable tty terminal, which I have to keep awake with regular Ctrl + Alt + F1 (or F3 ???).

The way out is to type sudo apt-get purge nvidia* and reboot. And then I'm back to the first point, with a working computer but with only one screen. I'm a web developper and this is surprisingly annoying.

Perspectives

Not much. The driver I downloaded is NVIDIA-Linux-x86_64-367.35.run and it was out on the 2016.7.15. My main strategy now is to wait for the next version.

I also used the graphics-drivers ppa way suggested by Stormlord, same result.

I tried everything from this post, and I don't know, maybe I should try randomly other versions of the official plugin.

The *-display UNCLAIMED part of the return of sudo lshw -c video is another thing to clarify. Seems like something that need a working plugin to be solved.

I will not downgrade to 14.04. Everything else is working well, I keep working on my computer and I need it to continue.

Edit 23/8/16 I just tried the plugin nvidia-370, from the additional plugins app. Same result.

Your driver exists in the graphics-drivers ppa. You can add the ppa to your system and install the driver.

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

Then look for the package with the correct version (367.35) and install it. It should be something like nvidia-367.35or nvidia-367.

  • I just did re-tried it, and I got stuck into the login loop again. – Ruff9 Aug 6 '16 at 19:42
  • I guess you have also disabled secure boot, right? – Stormlord Aug 6 '16 at 19:45
  • yes I did. I'm thinking about lightdm now, I already reinstalled it but maybe I can try again. Looks more heavy, loads directly to a tty terminal. – Ruff9 Aug 6 '16 at 19:56
  • sudo apt-get install nvidia-384 will well work. – KyungHoon Kim Nov 26 '17 at 3:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.