So after alot of googling I even found other answered questions on the topic that said a fix was always along the lines of


This is a common Ubuntu bug. Try to do this: Back up the xorg.conf file

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.orig

May the files doesn't exist. This is not necessary.

Anyway edit the file with sudo nano /etc/X11/xorg.conf and paste this:

Section "InputClass" Identifier "Mouse Remap" MatchProduct "Saitek Cyborg R.A.T.3 Mouse" MatchDevicePath "/dev/input/event*" Option "ButtonMapping" "1 2 3 4 5 6 7 0 0 0 0 0 0 0" EndSection

Press Ctrl+O to save and Ctrl+X to exit the editor. Reboot for functionality! "

However after Trying said fix. I can now oddly left click panel buttons on the left in unity. However left clicking in any windows still doesn't work Ie. I can click firefox and launch it but can't interact via mouse with firefox in any way. (or any other application including things like system settings app) Not quite sure where to go from here. I do have two mice on the system at one time which may also be part of the issues. I have a logitech K400r keyboard with mousepad. Being a truck drivers most days I just use the mousepad but when space permits like right now I am at a desk in a hotel. I use my Mad catz mouse to play games and just for better and faster use of GUI. Thank you and I hope this isn't too much of a stupid or bothersome question. I just created my account in so many years with ubuntu I never had to use AskUbuntu. I was just going to comment on the old problem but I didn't have the Reputation to comment.

  • It might be better to cut out the last paragraph in your question and add it as an answer: it would be clearer to read. – anonymous2 Aug 7 '16 at 3:05
  • Okay! sorry Just wanted to make sure I got the answer in there since I figured it out for anyone else who has the same issue. – Kain Kitsune Aug 8 '16 at 15:52

Issue fixed by adding .conf file into /usr/share/X11/xorg.conf.d/ I made a file called mousefix.conf and put the following in it

Section "InputClass"
    Identifier "Mouse Remap"
    MatchProduct "Madcatz Mad Catz R.A.T.3 Mouse"
    MatchDevicePath "/dev/input/event*"
    Option "ButtonMapping" "1 2 3 4 5 0 0 8 9 0 0 0 0 0"

Section "InputClass"
    Identifier "Mouse Remap"
    MatchProduct "Saitek Cyborg R.A.T.3 Mouse"
    MatchDevicePath "/dev/input/event*"
    Option "ButtonMapping" "1 2 3 4 5 0 0 8 9 0 0 0 13 14"

Saved it to /usr/share/X11/xorg.conf.d/ and rebooted all fixed!

  • Please format you text properly with the editor, e.g. mark code snippets as code. – LiveWireBT Aug 7 '16 at 0:31
  • Sorry New to Ubuntu Ask trying to. I tried the <pre> tag that didn't work.. working on it! edit: is that correct? I used <code> tag – Kain Kitsune Aug 8 '16 at 15:51
  • The easier way is to use markdown, since html pre doesn't work indenting an entire section would have been the best way and the editor would have done the with one click :) askubuntu.com/help/formatting edit: don't forget to accept answers, even if it is your own – LiveWireBT Aug 8 '16 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.