21

I have upgraded from Ubuntu 14.04 to Ubuntu 16.04 and now when I open Display Settings I get the message "Could Not get Screen Information"(here is a screenshot): Could not get Screen information

There are multiple questions related to that and I think this answer was most useful. I logged in with another user and for him the Display settings menu works just fine. So following the answer I get to the conclusion: It's likely going to be something in .gconf or .config in which case you have to dig deeper. The problem is that I don't know how to dig deeper.

I have already tried solutions in many other answers. I have reinstalled nvidia drivers, ubuntu-desktop, xorg, xserver-xorg and all other tips from this answer(short of fresh install that I really want to avoid).

I am using ubuntu 16.04(4.4.0-31-generic amd64) on lenovo w530 laptop. Any ideas on how I can fix the issue?

28

If you do a ps x|grep control-center command in a terminal window, you may expect gnome-control-center as result. Close this control center window and instead type unity-control-center in a terminal window.

This control center will show your screen information. Pin it in the launcher for future use and possibly pin out the former one.

  • I am using the display menu in settings. Am I supposed to pin out "Settings" launcher? – izomorphius Aug 8 '16 at 15:13
  • 2
    The update to 16.10 completely removed the unity-control-center and only left the gnome-control-center - very weird. Installed the latter and removed the former, now the displays are shown - but the online-accounts button is missing. Classic Linux tinkery. – Nearoo Oct 15 '16 at 18:30
  • I had the same issue, in 16.04, suddenly, when attaching a new display. This answer solved my issue. – Christine Nov 28 '16 at 9:29
  • 5
    Perhaps obvious, but sudo apt-get install unity-control-center if needed. – khaverim Feb 27 '17 at 17:41
9

reinstalling the Unity Control center worked for me :

sudo apt remove unity-control-center

sudo apt install unity-control-center

(Ubuntu 16.04 with Unity)

  • 2
    There are dependencies that could result in problems. The following packages will be REMOVED: ubuntu-desktop unity-control-center unity-control-center-signon Give apt-get install unity-control-center --reinstall a try instead. – lobner Sep 11 '16 at 14:36
6

I've some trick for this: right click on screen, choose "Change desktop background", click on "All settings" and go to "Displays".

This way it's works for me, but through Settings -> Display doesn't

  • thanks! worked for me as well – Uberto Apr 1 '18 at 19:58
  • ya strange but this works for me too – nuttynibbles Sep 25 '18 at 2:50
1

I had the same problem with 16.10. At some point, I did some clean up and one of the following removed unity-control-center:

sudo apt full-upgrade
sudo apt-get autoremove

The solution was to manually reinstall unity-control-center:

sudo apt install unity-control-center

I now see 2 Settings apps in Dash: "Settings" (gnome-control-center) and "System Settings" (unity-control-center).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.