0

i was trying this tutorial(https://help.ubuntu.com/community/EOLUpgrades#SpecificOlder) to upgrade Ubuntu 10.04, but always failed. source.list

deb http://old-releases.ubuntu.com/ubuntu/ lucid main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ lucid-security main restricted universe multiverse

i execute the command : sudo do-release-upgrade -d the last display on terminal is :

Restoring original system state
Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

During upgrading, there are some error when loading Failed Read Mirror File

and error

 Hit http://old-releases.ubuntu.com lucid-security/universe Packages
    Hit http://old-releases.ubuntu.com lucid-security/multiverse Packages
    Err http://archive.ubuntu.com lucid-updates/main Packages
      404  Not Found [IP: 2001:67c:1360:8001::21 80]
    Fetched 0B in 0s (0B/s)

i dont know where archive. ubuntu. com come from, there is no on my source.list

i also follow this solution (askubuntu. com/questions/91815/how-to-install-software-or-upgrade-from-an-old-unsupported-release), but not work on me, the error still occur

Any solution? thank you

1

Can you test if your internet connection is IPv6 ready with http://www.test-ipv6.com? Maybe that's the problem. If you can't connect via IPv6, then try the following:

1. In Terminal, type "pkexec gedit /etc/gai.conf"
2. Uncomment (i.e. remove "#" at the beginning) the line "precedence ::ffff:0:0/96 100"

After that, IPv4 connection should be used and upgrade process should work.

  • yes, maybe the problem in IPv6. i try uncomment "precedence ::ffff:0:0/96 100", then i execute "do-release-upgrade", the problem still exists. Then i try execute "lynx test-ipv6.com" the output is " Looking up www.test-ipv6.com Making HTTP connection to www.test-ipv6.com Alert!: Unable to connect to remote host. lynx: Can't access startfile test-ipv6.com " – rey1024 Aug 7 '16 at 1:04
1

Others have found that the update reports an authentication problem, and lists all the packages that were unauthenticated, then does a rollback.

According to this: https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1513232

there's a bug where the 12.04 packages appear to be unauthenticated to the do-release-upgrade. The bug report includes a couple of potential workarounds. The one suggested in the original report worked for me.

  • While I didn't see the message "Error authenticating some packages" in the output from do-release-upgrade, the workaround mentioned in the link you provided also worked for me. – Alan Mar 16 '17 at 16:15

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.