I have Ubuntu 16.04.1 and when I right click a photo and select "Set As Wallpaper" the function does not work. But I am able to get it working by going into System Settings and using the + button in Personalization to set a new wallpaper. It's very annoying though, is there any way to fix this problem?

updates:

  • I tested on another account and the problem went away
  • there are no other DEs installed. GNOME was previously installed but it is now uninstalled.

update:

it doesn't work on Thunar either. Forgot to say that I had recently switched to Thunar for my file manager (but my desktop is still Unity)

  • 3
    Does this happen for all images, irrespective of image type or is it only for, say, png or jpg pr whatever? – terdon Aug 24 '16 at 14:09
  • 3
    Have you installed any other Desktop Environment such as Gnome-Shell or Cinnamon? – Anwar Aug 24 '16 at 14:12
  • 3
    So what exactly happens? Does your desktop image change to anything? Or does it just stay as the previous one? Please also check whether or not the image you are trying to set as your wallpaper is present in the ~/Pictures/Wallpapers folder ones you have tried to make it your wallpaper. – user364819 Aug 24 '16 at 14:22
  • 1
    And I am assuming that this is in Nautilus? – user364819 Aug 24 '16 at 14:26
  • 2
    @JamesTobin I've added an answer and let me know if that works – Anwar Aug 24 '16 at 15:41
up vote 6 down vote accepted

OP installed Gnome Shell on top over Ubuntu at some point in time. Though removed later, It left some user-specific settings on user's profile.

Open a terminal and use these two commands to fix the problem.

gsettings set org.gnome.settings-daemon.plugins.background active true
gsettings set org.gnome.desktop.background show-desktop-icons true
  • The first command restore the right click -> Set as Wallpaper functionality
  • Second one gives you the ability to right click on the desktop to bring the menu.

After that two command, use this to set nautilus handle your desktop

xdg-mime default nautilus-folder-handler.desktop inode/directory

That should fix the problem for nautilus.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.