1

I'm using Ubuntu 14.04 LTS server edition as a home server, and i created a raid0 array from my two old 298 GB external HDD-s. After some time, when tried to copy some files i run into the error: 'Error copying files: Read-only filesystem. And because i was unable to umount the array i just rebooted the computer. However the startup has stuck at mounting the array, so i selected to fix it manually but when i tried to mount the array, it failed bicase 'the device is not ready', so i started e2fsck, but it failed at 99% with the message: I/O device error or something like this (i can't remember the exact message).


I thought that maybe one of the drives had died, so i shutted down the computer and connected the drives to my laptop to check them with DiskInternals' Linux Reader under win8.1. The program saw the array and could access and save it's content to somewhere else.


Rebooted the laptop to boot into Deepin 15.2 and started the repair process (assembled the array and then started e2fsck). Result: everything's fine with it. Mounted it and an r/w test (copied some random files to some random directories on it) indicated the same: everything's OK. When the server started up again, an e2fsck had run, but this time without errors. I rebooted it 3 times and it rebooted 3 time without any error, so i put it back to it's place.


After that, the I/O error never happened again, but the read-only fs did. A reboot solves it, but I'd like to know why is this happening and how to fix it permanently (if possible). The array contains a Samsung S2 Portable USB 2.0 external hdd and a 2,5" Samsung HN-M320MBB hdd in a usb 2.0 enclosure.

sorry for the grammar, i'm not native english

  • Can you please post the output of the dmesg around the time of your r/o fs events and the output of the smartctl command for these disks? – Phillip -Zyan K Lee- Stockmann Aug 5 '16 at 19:46
  • This is all i could get: Samsung S2 Portable Samsung HN-M320MBB – user275214 Aug 7 '16 at 15:12
  • @Phillip -Zyan K Lee- Stockmann: Here's a strange error: one of the HDDs gets unmounted while the array is still active and being used. A reboot fixes it, but before reboot i redirected the output of dmesg and uploaded it. – user275214 Aug 9 '16 at 21:53
  • My guess would be that the USB controller chip of the external disk that fails is going broke. Either this or the disk itself will die soon. – Phillip -Zyan K Lee- Stockmann Aug 10 '16 at 4:58
  • 1
    @Phillip -Zyan K Lee- Stockmann: It seems like it is neither the USB controller chip nor the HDD itself. It is the cable what seems to be causing the problem. I had to swap the two cables and it seems to be working (for now). – user275214 Sep 1 '16 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.