0

I'm new to ubuntu and I'm trying to download wine. I follow the instructions on the site and this message pops up in terminal:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-devel : Depends: wine-devel (= 1.9.15~ubuntu16.04.1)
E: Unable to correct problems, you have held broken packages.

I then tried using the command sudo apt-get install -f and got the message:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

So obviously, nothing happened. If anyone knows any easier installation method or commands that can help, that would be greatly appreciated.

  • Best advice you can get: don't install it. Use VirtualBox or VMWare and install Windows in there. I can predict that any software that is on the heavy graphical side and you want to run inside Wine is going to suck in perfomance and quality. And wont just work without tons of tweaking. – Rinzwind Aug 5 '16 at 17:54
  • You could try installing the version of wine in the repositories from the software center – Elder Geek Aug 5 '16 at 17:55
  • @Rinzwind Thanks for the suggestion, ill try it and hopefully that works – Aryan Gupta Aug 5 '16 at 18:00
  • @ElderGeek I dont know why but everytime I load up ubuntu Software, wine is always not able to be found – Aryan Gupta Aug 5 '16 at 18:01
  • is it installed? Open a terminal and enter the command which wine to find where it is or wine --version to determine the version installed – Elder Geek Aug 5 '16 at 18:13
1

First try to purge/uninstall wine. From this answer you can do this with:

Delete configuration and other wine related files:

rm -r "$HOME/.wine"
rm  $HOME/.config/menus/applications-merged/wine*
rm -r "$HOME/.local/share/applications/wine"
rm $HOME/.local/share/desktop-directories/wine*
rm $HOME/.local/share/icons/????_*.xpm

Delete packages and clean your system:

sudo apt-get purge wine winehq-devel wine-devel
sudo apt-get update
sudo apt-get autoclean
sudo apt-get clean
sudo apt-get autoremove

After that you can reconfigure (see here for info) your packages to fix them if something is broken:

sudo dpkg --configure -a
sudo dpkg-reconfigure -phigh -a

Then you should be able to install wine properly. Keep in mind that staging and development versions may have bugs (that could theoretically even prevent proper installation). On the other hand I understand that you may need the latest version to play a game after last update.

  • when ever I try this string of commands, at sudo apt update this message pops up: ** (appstreamcli:15637): CRITICAL **: Error while moving old database out of the way. – Aryan Gupta Aug 6 '16 at 20:06
  • which command gives this error? – Karsus Aug 6 '16 at 21:08
0

If you're new to linux and want to use wine, I recommend you try PlayOnLinux first.

You can download the installer from their website.

https://www.playonlinux.com/

Or from the repository

sudo apt-get install playonlinux

  • For some reason, even play on linux wont install. I think my only resort is using a VM – Aryan Gupta Aug 5 '16 at 18:12
  • Did you purge wine already? – Giovanni Caligaris Aug 5 '16 at 18:18
  • Everytime I try and download anything from Ubuntu Software, the install meter quickly flashes to about 20% then dissappears without any feedback – Aryan Gupta Aug 5 '16 at 18:51
  • 1
    Try this. sudo apt-get purge --remove wine* && autoremove. It seems that there is a broken package that needs to be solved. – Giovanni Caligaris Aug 5 '16 at 18:53
  • I tried the commands but that didn't change anything. Is the fact that im using a bootable usb instead of actually installing it matter – Aryan Gupta Aug 6 '16 at 20:13

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.