0

This question already has an answer here:

I'm trying to fix my grub but I can't manage to do it alone apparently...

I'm using a dual boot ubuntu 14.04 and windows7. I needed to shrink the partition size of the windows and used easyus for that. Problem, it apparently shot the Grub when shrinking the partition...

I can't boot any session anymore (unknown filesystem error which left me with a grub rescue prompt)

I tried to boot on a live cd (v14.04) to fix the grub using these lines:

ubuntu@ubuntu:~$ sudo grub-install --root-directory=/mnt /dev/sda
Installing for i386-pc platform.
Installation finished. No error reported.

But then the update doesn't pass:

ubuntu@ubuntu:~$ sudo update-grub2
/usr/sbin/grub-probe: error: failed to get canonical path of `/cow'

I tried this

sudo mount /dev/sda1 /mnt
sudo chroot /mnt
sudo update-grub2

but got the same response...

ubuntu@ubuntu:~$ df
Filesystem     1K-blocks     Used Available Use% Mounted on
udev            16422596        8  16422588   1% /dev
tmpfs            3286932     1552   3285380   1% /run
/dev/sdd1       31113360  3208464  27904896  11% /cdrom
/dev/loop0       1031296  1031296         0 100% /rofs
/cow            16434640    73072  16361568   1% /

marked as duplicate by Elder Geek, edwinksl, Anwar, Luís de Sousa, Eric Carvalho Aug 10 '16 at 13:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • you need to chroot from the live filesystem to yours in order to do that. Your attempting to update grub on the live media. There's a good answer on doing what you need to do here: askubuntu.com/questions/493612/how-to-reinstall-grub – Elder Geek Aug 5 '16 at 17:47
  • Thanks! I Must have missed this one! I'm trying right now. – Sebastien H Aug 5 '16 at 17:52
  • I'm not sure I understand completely the answer. What is the difference between sda5 and sda7 in Traklon situation? And I guess it is better to also create an additional mounting point since /mnt/root also exists in my case. (In the answer they suggested to create another one, eg /mnt/mydisk) – Sebastien H Aug 5 '16 at 17:58
  • Traklon situation isn't yours so it's not relevant. If you are unfamiliar with your partition structure you should try the boot repair approach. – Elder Geek Aug 5 '16 at 18:06
  • I'm currently installing it :) – Sebastien H Aug 5 '16 at 18:08

Browse other questions tagged or ask your own question.