When I installed Ubuntu I realized that I cannot connect to my home Wi-Fi at all, though wired connection worked perfectly. After a bit of googling I followed these instructions and it worked!

However, now my notebook uses my Wi-Fi for 5 minutes maximum. After that connection is lost. I need to reconnect again by switching off and on Enable Wi-Fi panel.

There was not such problem in Windows and all my devices works well with this wireless network.

If I should attach some output results from Terminal, please let me know, as I really do not know which commands to run.

UPDATE: wireless info

I'm using:

  • Asus X550C
  • Ubuntu 16.04.1 LTS
  • When exactly did you download the zip archive with the source code and installer? It may be worth to try a newer or older release. It would also be easier if you installed the driver with sudo make dkms instead of ./install (requires the dmks package but re-compiles the driver for every newly installed kernel). Aug 15, 2016 at 7:21
  • @DavidFoerster It was a week ago, when I installed drivers again after OS update as they were lost. Hmm. the dkms does not work. However, I followed these instructions, but replaced last string with sudo make dkms. Here is what I got. Maybe I should use --force flag on that?
    – Z. Zorg
    Aug 15, 2016 at 11:47
  • No, I don't think you should try --force. The messages mean that the driver is already included in Ubuntu's stock kernel and you shouldn't need to install any additional driver for that device. Aug 16, 2016 at 10:00
  • Hi @Z.Zorg, did you solve your problem? I have the same issue. This is related, but as somebody commented there, I have to repeat the process every now and then :/ Mar 26, 2019 at 18:54


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.