i recently finished shanto-imon) + and now Started Studying CHF so i needed 3 in 1 System and installed Windows 7 + ubuntu 14.04.5 + parrotsec (debian pentesting os), as i was installing 3 os in grub for the very first time i created swap for ubuntu and after completing installation ubuntu i created another swap for parrotsec os now they are like

  1. windows Disks
  2. Parrotsec disk
  3. parrotsec swap
  4. linux disk
  5. linux swap


    sudo update-grub

    Grub Os list

but the problem is when i run ubuntu 14.04.5 i see there is no swap memory detected as it shown on the screenshot below: No Swap memory detected

here is my disk's screenshot for better understanding: Disk's

i want the os to detect the swap memory not only Ubuntu but also other (if it possible to solve other os's swap memory Problem via ubuntu)

thanks in advance .

  • In terminal, type: "sudo blkid", and then edit /etc/fstab and make sure that your UUID's for the swap partition match. Then type: "swapon -a". You'll have to do this separately for each Linux OS.
    – heynnema
    Commented Aug 5, 2016 at 15:57
  • # /etc/fstab: static file system information. # Use 'blkid' to print the universally unique identifier for a # device; this may be used with UUID= as a more robust way to name devices # that works even if disks are added and removed. See fstab(5). # # <file system> <mount point> <type> <options> <dump> <pass> # / was on /dev/sdb7 during installation UUID=876a767a-d428-4b7e-8017-64bb8772a663 / ext4 errors=remount-ro 0 1 # swap was on /dev/sdb8 during installation UUID=f8b2c6c8-2f92-4d4c-9a79-31bd432ee4b2 none swap sw 0 0 Commented Aug 5, 2016 at 16:14
  • what to do now ?? Commented Aug 5, 2016 at 16:14
  • You need to do the "sudo blkid" command and match up the UUID for the swap partition in /etc/fstab.
    – heynnema
    Commented Aug 5, 2016 at 16:48


You must log in to answer this question.

Browse other questions tagged .