I want to share my desktop mouse and keyboard with my laptop using synergy. Until yesterday, both ran Ubuntu 14.04 and synergy 1.4, and everything worked fine.

Yesterday, I upgraded my laptop to Ubuntu 16.04, and apparently this one ships with synergy 1.6. As a result, it has now become impossible to share my keyboard and mouse, as synergy complains about incompatible versions. However, I have not found a clean way of either downgrading synergy 1.6 on Ubuntu 16.04, or upgrading synergy 1.4 on Ubuntu 14.04.

Is there a clean way to use synergy between Ubuntu 14.04 and Ubuntu 16.04 computers? I do not want to upgrade my desktop to Ubuntu 16.04 just yet.


I run into the same problem this weekend, the solution I found was upgrading Synergy on my Xubuntu 14.04 following this steps.

wget -q -O - http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -
sudo sh -c 'echo "deb http://archive.getdeb.net/ubuntu trusty-getdeb apps" >> /etc/apt/sources.list.d/getdeb.list'
sudo apt-get update
sudo apt-get install synergy

It actually updated from 1.4 to 1.7.6, and turning off the Encryption option on both "Server"(Xubuntu 14.04 with Synergy 1.7.6) and "Client" (Ubuntu 16.04 with Synergy 1.6.2) I was able to connect and use it again.

The strange part for me was that I didn't remember the option to register the app... I need to check this later again.

| improve this answer | |
  • I can confirm this. I have 1.7.6 running on 14.04 and 16.04 but with encryption on. If I remember correctly 14.04 also required an upgrade of SSL. – Rinzwind Aug 22 '16 at 14:20
  • cool! I was not happy leaving this option off. haha Are you running the Synergy 1.7.6 on both machines or just on the 14.04? – leomilrib Aug 22 '16 at 14:54
  • 14.04 and 16.04 and w10. w10 holds the server file. – Rinzwind Aug 22 '16 at 14:58
  • Thanks man @leomilrib ... been futzing around with this for aaaaages. – tink Jan 25 '17 at 1:10
  • having now the same problem for ubuntu 16.04 and 18.04 I don't know why synergy always breaks BW compatibility. It's in my opinion not a helpful choice. I understand that it's not enabled by default, but it should be possible to listen to old protocols either on a client basis or as a global setting – gelonida Dec 8 '19 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.